Motors won't spin up

I installed my new Holybro Pixhawk 6C Mini on my Holybro X500 frame using firmware 4.3.1 on Mission Planner. There was a pull-down menu specifically for this aircraft which uses 20A 4S BL-HELI_S ESCs. I set the quadcopter up per instructions, and it worked just fine. Recently I had the quad on the laptop, and Mission Planner said there was a new firmware 4.5.1 and asked me if I wanted to upgrade. I agreed and installed the new firmware. Now the pulldown menu for a Holybro Pixhawk 6C Mini on a Holybro X500 frame is gone, and I can’t get any response out of the motors. The aircraft will arm and there are no errors, but the motors will not spin up. The Servo page in Setup shows all motors stuck. I tried calibrating the motors, but that did nothing. I’m clueless. What’s going on?

Here is what you should do:
Flash the Bdshot version of firmware to the 6C.
Flash Bluejay firmware to the ESC’s
Configure for Bdshot

Hi @marlinlinger,

Re, “the pulldown menu for a Holybro Pixhawk 6C Mini on a Holybro X500 frame is gone” do you mean one of the parameter files that appears in the right drop-down on MP’s Full parameter list?

By the way, if you get blocked with a new release not working you can always go back to the older release. Mission Planner’s

We are quite careful with releases to ensure they are stable and we prioritise fixing bugs over enhancements but in case you need to backout to an older release, the option is there.

You know what would be nice? It would be nice if the Arducopter website had a page dedicated to Holybro frames and current Pixhawk setup. I suspect that most Pixhawk users start with Holybro equipment these days. The national student drone competitions almost all use them. That would be so much better than relying on forum websites and non-existent manufacturer and dealer support. It would hlep to bring the Pixhawk brand into the mainstream like DJI, rather than the piecemeal, backward, hobbiest system we have now. For what I’m paying for Pixhawk equipment, I shouldn’t have to go through forum bullshit like this. I should be able to wire up a Pixhawk quadcopter and have it in the air in ten minutes like a DJI. Somebody needs to take the helm and get this ship straight.

I have got a Holybro 500v2 with a Pixhawk 6c controller from Holybro for over 1 year. Everything was working fine until I upgraded the firmware to version 4.5.1: motors won’t spin. I downgraded to version 4.4.4 and everything works again. Has there been a major change in addressing the ESC,s?

Post your parameter file and the ESC’s you are using.

The esc’s are: Holybro X500 V2 BLHeli S 20A ESC
x500v2_210424.params.txt (30.1 KB)

Can you connect to the Flight Controller and Write the Parameter file from the Full Parameters List screen and post that? The format of the one you posted is a hassle to work with. Or better yet post a link to a .bin Flight Log of 4.5.1 after arming.

Thx for the assistance.
I am using QGroundControl (QGC) and the param file I have sent is the one obtained from QGC.
I uploaded a log file testing the quad to verify the motors (not spinning).
log_38_2024-4-27-15-31-30.bin (852.8 KB)

Do you have Bluejay firmware flashed to the ESC? (you should) If so set these:

Re-boot the board.

If not don’t set the BDMASK parameter.

And then re-configure the notch filter to use RPM.

1 Like

Thx, it works! I used:

1 Like