Motors speed oscilates during flight

Guys I upgraded to 3.5.3 from 3.4. Anyway today I was trying to enter autotune but before that action I noticed fast oscilation of motors speed - was in stabilize mode. Therefore I didn’t start tuning. I just recorded video from this flight and uploaded param file. Unfortunatelly loging doesn’t work for me since 3.5.3 upgrade so no log file :frowning:
If somebody can help me either with speed oscilation or with loging problem I would be really happy. I’m scary of flying my quad in other mode than stabilize - guess could fall down because of some EKF error - the speed oscilation produces huge vibrations though.
Here is the link to short video of flight, one can see it and hear best at 30 second:

19.10.2017.param (13.0 KB)

Try switching to Rover firmware and back to Copter.

Yeah, you can try different firmware, but that looks like the Roll/Pitch PIDs are out of whack, and it may just be the D term is too high.

If P was too high you get “slow” over shoot oscillations, and if D is too high you get more of a short rapid oscillation.

Which reminds me, post a screen shot of ConfgTuning > Extended Tuning so we can see what your current PIDs are…

Here are my PIDs:

Could it be something wrong about it?

How do you have d-gains without autotuning? Revert to default everything by switching firmware to rover and back to copter and do the wizard.

I think throttle Accel values are the cause of your issues. As Keith told: Start with default pids, and then, if stable, make the autotune.

1 Like

I tried one flight some time ago for autotune for a short time. Then followed crash from 4 meters :-(. After this crash I don’t want to try it with these oscillations. Therefrom are these PIDs I guess.
Anyway yesterday I found out strange thing. Before I describe it perhaps I should clarify mu setup:
RC setup:
Futaba 9C + ezUHF module and RX is ezUHF diversity.
Copter is of version 3.5.3 running on RBPi3 + PXFMini.

At last I managed copter to save some log file from very short flight for no longer than 1 second. It was only small jump to see if oscillation still persist and to see something in log file. Oscillations persists and when reviewed log file RC3 IN looked like saw :open_mouth: . Unfortunately I don’t have log file with me now to upload it and didn’t have time to look deeper if there are other symptoms but the fact the RC3_IN is sawing is pointing me to problem with RC signal from ezUHF.
I updated FW for my ezUHF gear and did some changes (22ms PPM frame to 28ms) because I need more than 8 RC channels.
So perhaps it has nothing to do with Arducopter SW and it needs deeper analysis. Unfortunately I don’t have a time for it now.

Is the reset of PIDs possible only via firmware switching? Isn’t there some params-reset in Missionplanner available?

Hopefully that was it …
In full Parameter tree or list is a button to restet settings to defaults.
But it may also be useful to flash the daughterboard again…
Flash something different than Arducopter and than back to Arducopter…
Be shure to backup your settings, and maybe carefully set them back via compare feature.

You should test one motor and esc with a servo tester e.g. quick changes from low to high and look for desyncs.
If you get some, your esc setup maybe wrong and it is not save to do a autotune!

This I already eliminated, it was the first thing I suspected. ESC and motors are OK.

Had the same thing Happen to me. Its seems as if autotune doesnt work properly anymore… those fast oscilations are a sign of a High D gain. turn it down to near zero but not quite. Then you will want to look into learning how to tune you copter yourself I learned most things in the documentation.

Having the same problem with oscilating motors but without autotune and even faster.
First tests on copter. Standard parameters.
Even keeping it still in my hand the motors are oscilating.
ESC calibration and radio calibration done.
Motor test done. At motor test i can even spin them up to 50% and they are running smooth.
Covered the pixhawk to eleminate possible propwash to the baro.

250mm Quad with 2306 27000KV 5040Props Pixhawk HAKRC BLHeli_32
Ardupilot set to DShot125


Just flashed Rover FW and back to Copter.
Followed the Wizzard.
Tried this time ESC protocol normal.

No difference… Still oscilating motorspeed.

Vibration chart seems to be ok. As far as I read at the internet.

Frustrating first steps… :cry:

post your pid’s

if p gains are at default 4.5, I gains at 0.01? I think is default, and d gains 0, then try changing EK2_ABIAS_P_NSE to .001.

I had the same issue, and seemed to have fixed it by dropping the P’s (top row) from 4.5 to 1.
I also tried smaller props, and that also improved the situation.

Get it flying stable before trying autotune.

I also found flying with a S3 battery, I had no issues, but as soon as I changed to a S4 battery, I had the issues.
The S4 battery has bigger and heavier, but don’t feel that added to the problem.

I set everything back to default now and redid the wizard.
I set EK2_ABIAS_P_NSE from .005 to .001
Mot_Spin_Arm from 0.1 to 0.05
Mot_Spin_Min from 0.15 to 0.1

Except for Roll and Pitch D I changend from 0.0036 to 0.0006 these are the standard params.

Still nothing got better.

1 01.01.2000 03-02-08.bin (313.2 KB)

P in first row excepts only 3 as lowest P Gain.

Have you calibrated ECS ?

Yes, several times. Also tried OneShot125.
Where I recognized a difference between german and english MP.
In german it says that I shoult lift throttle to 100% and plug in battery.