Motors on quad slows down very slowly

Guys I need help. when in stab mode, motors follows RC throtle stick OK but only when rising it. When want to slow them down (e.g. want to descent) they loose rotation very slowly. It is problem of software defnitely - when motors are connected directly to receiver they follow RC stick immediately, it doesn’t matter if up or down. But when connected to controller they follows RC stick immediatelly only when rising. When lowering it they loos RPM really slow.
Any clue? Could it be some PID problem?

Does that happens in any flight mode including Stabilize?

I didn’t test it on other modes than stabilize :frowning_face: In next session I’ll try some other modes.
But it is scarying me since I almost everytime crash the copter on landing - motors still rotating fast even on the ground and throttle stick on 0%. Copter then bounce from ground and because of propellers still rotating it lifts a bit from ground and tumble on its back :sob:

I believe you don’t have to test in other modes if this happens in Stabilize. It’s too dangerous.

You should perform a quick test to collect logs: hold your copter with your hand and give some throttle beeing in Stab mode. Then after motors spin up you need to quickly cut off your throttle stick.

So in the log there will be your RC signal and the Throttle Out signal that FC does pass to motors.
In that way you could clearly see if FC holds your motor level high or not.

Do you have programmable ESCs by any chance?
Some of them have delay when throttling up/down to prevent strain on drivetrains (in single rotor heli’s etc).

At last I made some flying and recorded log from it.
There it is - RC OUTs are really not following RC3 IN, or they do but with really long delay:

Here is part of log file: (236.9 KB)

Today I changed firmware to Arducopter 3.5.2, but with the same results or even worse.
Still have no clue :frowning:
Motors are sunnysky X4110S, 580 KV,
ESCs are Hobbywing X-Rotor ESC - 40amp (OPTO)
ESCs are properly calibrated.
As I already wrote, when ESC is connected directly to receiver, motors folllow throttle immediatelly. It is something in controller settings - may be incorrect PIDs ?

Is your copter overpowered? Because I see that you have MOT_HOVER_LEARN enabled and your hover level is 20%.
Also after you upgraded to 3.5.2, what is your MOT_SPOOL_TIME?

Perhaps it is little bit overpowered since I plan use some extra filming stuff on it.

OK, maybe someone will have an idea but I don’t see a problem in your log.
Yes there is a short delay between RCIN and RCOUT on your screenshot but this is not the case that you initially described.

As per your first post you have troubles with descending, so I proposed to simulate that case by increasing throttle to 25-30%, then after your props spin up, then pull down throttle quickly.

I see that RC OUT follows RCIN most of the time without any delay:

My only assumption is maybe you have a lightweight vehicle with some large and heavy props that can provide a lift spinning by inertia for some time after you decreased the throttle.
But in that case you should also notice stabilization problems when flying.

I did fresh measurement. Here is the proof the motors response to RC-in is really not correct and lazy:

Strange is - when pushing to higher speed (left part of the graph), RC-out response seems to be correct, but when trying only low speeds (three single glitches in the right part of the graph) the response is really bad.
And this is my problem when landing because at that moment RPM of motor is at low level, more specifically in the territory of howering and easy descend. When touching the ground I cut the motors completely down, but they are still spining for a while. And with combination of small jump because of landing gear springiness, copter lifts bit more and do tumble :frowning: .

And the whole log life:
2017-09-05 18-38-43.log (552.6 KB)

Please help :sob:

Did you saw this thread? Motor still spin after shut off

May be setting SPOOL_TIME to zero could help, though I did not found a explanation that setting affect spool down time.

Generally looks like there is a number of peoples noticed that motors don’t stops immidiatelly. And usually it is not a big problem, but in your case low RPM causes a noticeable lift?

Now I found the reason - it is MOT_SPIN_MIN. Anyway thanks for link to the thread. These guys seems to have the same problem.

@lospalos be careful, look at the MOT_SPIN_MIN description in

If you set it to zero then it is allowed for flight controller to out zero throttle when flying (on fast descendings etc.)
This definitelly could cause a crash because of stabilization lost.

What I’m assuming is that the “lazy” response on low throttle level is “as designed” in current FW. The correct solution for your case could be to add some weight to your copter to increase your Throttle Hover value. In that way you will not be affected by “lazy” response when landing.

Thanks for info on setting of motor range. By this it is really bad idea set it to zero. I will try to set it as low as possible.