Servers by jDrones

Motors not spinning until >50% RC throttle

(Andrew Paulsen) #1

I set up an S500 quadcopter with a Pixhawk 1 controller. I initially set it up with PX4 and it was working very well. Now I loaded Arducopter 3.6.10 and have everything set up and calibrated, but I’m seeing unexpected behavior with the throttle. In both motor test in Misison Planner and with the RC controller I cannot get the motors to start spinning until around 60% throttle. I’m in stabilized flight mode.

I think this is what the PILOT_THR_BHV parameter controls, but it was at the default value of zero, which should use the full range. I set it to 6 (and 7, just to see if it made a difference), but I see the same behavior.

Parameter dump.

Any ideas?

(Shawn) #2

Sounds like you need to calibrate the ESCs and then check MOT_SPIN_ARM and MOT_SPIN_MIN in conjunction with the motor test section again.
Probably a good idea to chech the radio calibration again too.

(Andrew Paulsen) #3

Ok, I didn’t expect it to work, but I redid the ESC calibration and now it does work properly. The previous calibration must have went very wrong somehow.