Motors not shown in motor test dialog (mission planner)

My motors dont show up in the MP motor test (mine on right in dialog below). X500 build, pixhawk 6c. RC, GPS, all working. Been stuck on this for days, endless youtube vidoes, param after param settings changes. Anyone have an idea? Greatly appreciated.

terry_params_24.0504.param (17.6 KB)

De-install misson planner and update to 1.3.81

Is your problem that the text isn’t displayed or is your problem that the motor test isn’t working at all due to that?
What happens if you just press “Test motor A/B/C/D”, ignoring the missing text?

I get the sounds, but no movement.

Tried all kinds of things… set motor spin arm, spin min. throttle, duration.
Problem is
(1) there are so many possible settings variations, (2) the settings are not that easy to understand (“set the min % that will be output when flying” ??.. i tried to change these before from the UI, but get an error (see below) ). I search for this phrase within ardupilot, but nothing (3) i have not found a youtube that really does a “clean” start to finish on setting this up to make sure the myriad of params are all correct…

I had the same problem in 1.3.81. Then found a great youtube vidoe that was for 1.3.80. So I switched (that was confusing… finding the versions, they dont uninstall each other…). I have spent a lot of time on this… I dont think its copmlicated, but I have no minimal doc that explains the steps to get there.

THe problem is, you all know what things dont matter, and I dont. And there are so many settings, they are not well defined.

“set the min % that will be output when armed, but still on the ground”… what does that mean?

is there a doc page somewhere for each MP dialog? is the required steps and order defined somewhere? I love the functionality that ardupilot offers, but seems i am not smart enough to even get off the ground :slight_smile: (with ardupilot)… trying to convince someone to use ardupilot instead of betaflight. for a project.

PS: i got ardupilot installed on my FPV drone (speedybee f405)… RC working fine (same tx-12 + RP1), HUD moves when i move copter, etc. but same problem with motors not spinning.

My intent is not to just complain about the missing info, but
to do something about it. My little hobby is to actually create a “drones for beginners” @ (the wiki/gdrive). A very conceptual presentation with detailed docs (word files, that have great detail and get updated regularly). So I am actually wanting to contribute to getting new blood into the ardupilot ecosystem.

Then start by reading and following the methodic tuning Blog post. And suggest improvements to the text where you see fit