Motors don't spin when i put propellers

My configuration is:

I ran mission planner Mandatory hardware calibrations

  • Everything went fine
  • WITHOUT PROPELLERS: I arm with button and arm with RC and EVERYTHING goes well and motors spin CCW (1 & 2) and CW (3&4) as expected - When I push motors they spin fast as expected.
    - WITH PROPELLERS: I put the propellers respecting CCW and CW, ARM with button and RC then motors start to wiggle left and right (like an engine without Gas) and some time one motor (out of 4) starts spinning

I can’t figure it out for the life of me.

I am new to setting up drones.

I am thinking it has to be with ESC calibration.

Can you help?

Electronic Speed Controller (ESC) Calibration — Copter documentation (

the escs will have a low speed protection, because your propellers are so big it thinks the motor is stuck and is cutting power. Unfortunately, I don’t think there is a way to change the settings on those ESCs. they look like rebranded simonk escs from years ago, they dont support any modern esc signals like oneshot or dshot.

you should look for blheli_s or blheli32 escs.

Replacing those ESC’s oldies is good advice. In the mean time post your parameter file. From the Full Parameter List, Save To File.

pixhawk 2.4.8 params.param (16.4 KB)
thanks for offering to help.
the file is attached.

I am new and I would appreciate some guidance .

I tried linking my Pizhawk to BLHeli suite 32 but got errors on connection too.

Those ESC’s are not capable of Dshot or Passthru to BLHeliSuite. So set MOT_PWM_TYPE back to default (0). You have MOT_SPIN_ARM set higher than MOT_SPIN_MIN. Set these back to default. Take the props off and in Mission Planner go to the Motor Test screen and starting at the default setting confirm the motor order and direction are correct. READ THE NOTE AND CLICK THE LINK to be sure you understand the order the test runs in. If all is well at this point increase the throttle % incrementally and confirm the motors are responding in increasing speed.

Hello - Thanks for the note.

What i did:
1- reset all parameters
2- recalibrate everything from scratch
3- ESC calibration as NORMAL
4- Parameters

  • Defaults MOT_SPIN_ARM @ 0.1
  • Defaults MOT_SPIN_MIN @0.15
    5- Went to Motor Test
  • I tested Motors A, B, C and D without propellers and everyting went well at Throttle @ 2%
  • When I put a propeller on Motor A for example, I need to go to Throttle @ 25% to have the motor move (Wiggle) and then stop spinning


You need to replace those ancient ESCs. they are essentially running almost 10 year old firmware.

I will at some point… waiting for Dave’s last inputs.

As you are suggesting a chnage of ESC: any suggested brands and models?

I am running the whole thing on 2S battery. Would it make a difference if i add another battery in series to make a 4s?

2s might not be enough to get them started, so its worth trying them on 4s.

any blheli 20a esc should work fine.

1 Like

Based on the motor size you say you have (what size props?) I don’t think 2S power would get you off the ground even if they did spin with props on. As @geofrancis says replace those with some BLHeli_32 ESC’s and then you won’t have to worry about ESC calibration (not required) and there are other advantages.

Hello everyone. 2 put closure to this thread
1- I got a 4S battery
2- motors spin with propellers now

case closed.

Conclusion: my ESCs being basic, they couldn;t start off unless powered with 4s though they support 2s