Motor spins up on Disarm

H743 Wing with Hobbywing 30A V5 esc, controlled with logitech 310 control pad.

Arm checks have been disabled for this bench testing.

Happy with the throttle function in manual mode, i finally got the servo outputs sorted out from the left joystick with centre being stop and full up being full throttle.

Was running MP connection with usb at the time.

The problem is that on disarm via MP on laptop, the motor will spin immediately from stop to max rpm. On arming the motor stops and throttle works perfectly.

Appreciate if there is any feedback or opinions about what might be the best place to start.

This seems like you double-reversed the throttle channel on both the RC receiver and output throttle channel on autopilot.

I’m sorry but I’m not sure what that means about the double reversal.

I dont have an rc controller in my build, with everytging happening by mavlink via a control pad and my laptop and then a RFD900x setup.

This was happening this time, while using a USB cable to supply the link to the flight computer.

You should be able to control the throttle correctly on auto modes.
If you’re only able to use the throttle correctly in manual mode, this means that the throttle on your manual input is reversed and also reversed at the output. This cancels each other and only gives you valid output in manual mode.

Thanks for taking the time to reply.

I just ran through another check to confirm.

Using rfd900 for mavlink.

motor worked in manual as it should. Accelerate to max speed smoothly and stop when stick returned.

This worked again perfectly in stabalise and FBWA. When switching to FBWB there was an immediate uncommanded thottle to max - disarm had no effect. Battery disconnected to stop.

Not sure where to go with this one now.
Because manual, stabilize and fbwa modes are manual throttle-controlled flight modes.

Thank you very much for explaining it to me simply. Just took me a little to figure it out.

I managed to get it sorted and appears to be working now and disarm now works in all modes. I think initially I was trying to set it up any way I could because it was all pretty unfamiliar. Using a centring control pad joystick for the throttle challenged me.