Servers by jDrones

Motor not starting? Throttle not working

Hi Everyone,

First off, I just want to say that I appreciate any help in advance because I am driving myself crazy trying to figure this out.

Basically, I am trying to setup a simple fixed wing plane using arduplane, pixhawk 2.4.8, and mission planner. I followed all the steps online and watched videos (Painless360) helping to set it up. Everything works perfectly except the motor won’t start and I can’t throttle it. On the servo configuration page, the throttle bar correctly follows the inputs from the transmitter. For reference I am using the Taranis Q7X7 and X8R. I am using a simonk esc and a multistar motor. I have used all these exact components for quads before and it works great (I went back and made another quad today with the same equipment to make sure it all still works and it does). I am also running the latest version of arduplane (I believe 4.0.5).

Thus far I have tried using older firmwares, different esc/motor combinations, and Qgroundcontrol. I have tried the method of manually calibrating the ESC by powering it separately with the RC throttle all the way up and then powering it down (this did not work). I know all my hardware works and I can tell that the receiver is getting the throttle inputs because they show up on both the radio calibration and servo page. I am using the standard method of throttle on channel 3. Like I said the servos all work and move to stabilize the plane when I move the pixhawk around.

It seems like the issue is somewhere between the pixhawk communicating with the esc. Like I said earlier, it’s weird though because the same rails on the pixhawk work with the same ESC/motor when in arducopter.

If anyone has any ideas or needs more information to help, please let me know!

Thanks

Are you armed? Have you pressed the safety switch if you have one, or disabled BRD_SAFTEYENABLE if you haven’t?

https://ardupilot.org/plane/docs/common-safety-switch-pixhawk.html

What mode are you in? Manual would probably be the best thing to try first.

Thanks for the reply Peter. Yes I am armed and have pressed the safety button. I’ve tried it in manual, stabilize, and FBWA.

A log will help us diagnose,

https://ardupilot.org/plane/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html

Great idea. I’ll get that out tomorrow ASAP!
Thanks

I would first check if it’s working in manual mode. If yes, then that means it’s affecting FBW and Auto modes.
I believe you have to go into takeoff mode first, get some airspeed, and then switch to auto or FBWA mode. I think the motor will spin up once the AP thinks it’s in the air (positive airspeed, IMU detects flight and etc).

@iampete Thanks for the help! I am attaching the log information and more here.

Here is a screenshot of the log using auto analyze. All I did was plug in the pixhawk into the battery. Wait for it to get a gps lock. Put it in manual mode. Press the safety switch. Arm the throttle. Then move all the servos around (which worked) and tried moving the throttle but it did not start or respond. I then disarmed the throttle and plugged the pixhawk into my computer to get this information.

Here is a link to the .bin file (too large to upload here)
https://drive.google.com/file/d/1BKJQXOLxMDKzedddTpvkB-XugaM4XR9c/view?usp=sharing

Here are the messages once I plugged the pixhawk in. I re-armed and disarmed the throttle a couple of times just to show that it works using the transmitter.

Here is the servo output page on mission planner. I can move all the servos and they respond in real life. When armed, I can also move the throttle and it responds virtually on the green bar but not in real life.

Here I show the flight mode screen where I can change between manual, stabalize, and FBWA

Finally, here is the ESC calibration error that I keep getting. It won’t let me calibrate on mission planner. I have tried the manual method of calibrating mentioned on ardupilot many times but that has not worked either. Here is a link to that method
https://ardupilot.org/plane/docs/guide-esc-calibration.html

ESC Calibration Error

Thanks for any help!!!

-Jake

@MCITYFC thanks for the response. Yeah it is not working in manual mode either. I am not using an air speed sensor. Although from my research it seems like the motor should still be able to start even without the sensor.
-Jake

I think plane calibration doesn’t use the button in MP, although I could be wrong.

Seems like your setup is OK. Maybe 1100 is just to high for the ESC. Try setting the throttle servo output range to 1000 to 2000.

If your method of manually calibrating the esc through the pixhawk did not work, then i would check the signal and ground cable continuity.
Or perhaps the protocol? Oneshot etc?

FYI calibration for plane does not work through MP. I power the FC from another power source such as a usb supply etc and the arm the plane, put in manual mode, thottle full up and immediately attch the battery. This helps me calibrate the ESCs. Remmber though, if you do not power up through battery at full throttle while armed, you start low battery error after about 5 seconds. Then you have to repeat the whole process again.

@iampete Changing it from 1000 to 2000 seems to do the trick! Thanks so much!!!

Can you explain what exactly changing those numbers do? I’m kinda a noob but from my understanding it is the PWM values which basically allow the ESC to be controlled by changing the duty cycle to achieve different levels of throttle while using a constant voltage.

For this application, why would using a lower PWM value now work? Any simple explanation would be great to help explain this.

Thanks again so much!

-Jake

Its a built in safety feature of plane ESCs. The idea is to stop them spinning up if you power them up and accidentally left the throttle high. They must see some minimum PMW before they will enable. Some times this min PWM is hard coded and doesn’t take the calibration. A nice feature of a RC plane but kind of annoying for ArduPilot vehicle.

2 Likes
Servers by jDrones