Mot_pwm_type is missing, can't get blheli32 working

ESC Blheli32, that’s my config setup

ESC connected to channels 2,3 (Function Motor 1, Motor 2)

The issue is that ESC not beeping and doesn’t react on the throttle when armed.
Lots of docs about changing mot_pwm_type, which is missing in my config list, I am using Arduplane 4.3.1.

Thanks for the help.

12/9/2022 10:08:10 AM : ArduPlane V4.3.1 (7d0c6e4d)
12/9/2022 10:08:10 AM : IMU1: fast sampling enabled 2.0kHz
12/9/2022 10:08:10 AM : IMU0: fast sampling enabled 2.0kHz
12/9/2022 10:08:10 AM : RCOut: DS600:1-6 PWM:7-13
12/9/2022 10:08:10 AM : MatekH743 0032002B 32305105 35363730


Changed to Throttle, and it works now. Just magic.

Could somebody explain why mot_pwm_type is not present? Or it’s only in ArduCopter?

MOT_PWM_TYPE isn’t present on plane. On fixed-wing it will use PWM by default on the “throttle”, “throttle left”, and “throttle right” outputs. The “motor” outputs only come into play for quadplane VTOL aircraft.

SERVO_BLH_OTYPE sets the protocol for the output channels given by SERVO_BLH_MASK, as you have done.


Nice! Thanks for the explanation. So if I will plan to do a VTOL, do I need to flash arducopter firmware?

No, the same setting is in Q_M_PWM_TYPE

1 Like