Mode switching not working after converting pixhawk from px4 to arducopter

I am trying to get a “UAV solution phoenix 90” airworthy after purchasing it used, I am not experienced in tuning using px4 and could not get the craft stable in flight so I flashed the pixhawk with “pixhawk 1” 4.0.7 arducopter firmware using this process
https://ardupilot.org/copter/docs/common-loading-firmware-onto-chibios-only-boards.html#common-loading-firmware-onto-chibios-only-boards

Before I continue I need to mention the remote and telemetry is a herelink system. The problem is after I assigned a flight mode switch, modes, and correct pwm values switching between loiter & stabilize is not displayed on the herelink nor mission planner telemetry screen, I can see the switch taking place in the “flight modes” section of mission planner and on the herelink however it does not change in the correct spot. This worked perfectly before switching from px4 to arducopter. I thought I found a solution on this thread

However in the last post which appears to sum up the problem I cannot find “source_system=1” my understanding from the article was the mavlink protocol the telemetry normally communicates with the ground station on is being jammed by too many signals, causing some inputs on the ground station/remote to not effect the craft, which is a problem because I need to be able to change modes. Thoughts?

I think you should go to the settings of QGC and there you can change the MavLink system Id which QGC is using.

https://docs.qgroundcontrol.com/master/en/SettingsView/MAVLink.html

But I wonder what should have changed compared to the PX4 setup which could make this change necessary.