MissionPlanner 1.3.45 cannot connect to PixRacer ESP8266


This is my first support request for Mission Planner on this forum, apologies if this has been asked before but I could not find something that could work.

I have an AUAV.co PixRacer running ArduCopter 3.4.5. The PixRacer has an ESP8266 WiFi board which is running MavLink ESP8266 firmware v1.1.0. I am using Mission Planner 1.3.44 on two machines (one notebook and one Intel tablet), both running Windows 10 Pro x64 and using Intel PROwireless driver (the latest version from Intel). I can connect without issues to the “PixRacer” AP via Mission Planner 1.3.44. The connection settings are UDP at 921k baud, using the standard connection ports.

Upon upgrading to Mission Planner 1.3.45 (tried both in-place upgrade and uninstalling/re-installing the software), I’ve noticed a change to the connection behaviour; Mission Planner upon finishing loading tries immediately to connect via UDP to the PixRacer, even if the board is not initialized. Subsequent efforts to connect to the board (after powering it up) fail and it is no longer possible to connect to the PixRacer via WiFi. Connecting via USB or 3DR MavLink telemetry works as expected, only the UDP WiFi connection is no longer possible. Shutting down Mission Planner, rebooting the machine, rebooting the PixRacer, connecting the PC to the PixRacer AP and then starting up Mission Planner does not change anything; I cannot connect to the PixRacer via WiFi.

I have reverted back to MP v1.3.44 where everything works fine but I would like to know if it is possible to mimic the v1.3.44 connection behaviour on MP v1.3.45 in order to be able to connect via WiFi to the PixRacer.

Thank you very much in advance for your help.


You will get a faster response if you post your issue on the Github Mission Planner. Here is a link to the site. https://github.com/ArduPilot/MissionPlanner/issues
If you don’t already have one you will need to create an account to leave an issue.

I’ll open an issue there, thank you very much for the suggestion.

I was wondering if you received an answer to your question. I am having the same problem. I would like to make a wiki page if you do.


You can find the open (and still unresolved) issue here.

I gave up on dealing with Mission Planner on my tablet, switched to Android Tower. Mission Planner is extremely unreliable with PixRacer and I do not think the maintainer is interested much in dealing with PixRacer.

I use Mission Planner (1.3.49) and Tower interchangeably with 2 Pixracers and the ESP8266 radio and they both work OK.

Just completed an update on 2 Pixracers yesterday without an issue.
Using Mission Planner latest release.

It did spit the dummy on one of the two Pixfalcons I was updating though and I could find no reason.
One Pixfalcon updated fine, just as the Pixracers did, but the other just would not recognise the board and kept telling me to check the cables.
This was during a batch update of 2 Pixfalcons, 2 Pixracers, Pixhawk 1 and Pixhawk 2, all on the same machine and USB cable.
Tried updating Mission Planner to the latest beta, no change, just wouldn’t identify the board after plugging it back in.
Figuring this is just another Windoze idiosyncratic anomaly, Itook the copter into the office, plugged it into a Mac and kicked up APM Planner 2 and it did the update immediately without issue.

My conclusion, That’s Windoze for you. :wink:

I use three different Windows PCs and a Windows tablet. All machines run Windows 10 build 1703, three of them are running x86_64 and one (the tablet) x86 variant. All devices have at least one network card (the tablet) or more than one (the other three). On ALL machines, MP 1.3.49 cannot connect to the PixRacer via the provided WiFi module and this is reproduced every single time. Even performing a clean install of Windows on one of them, did not change anything.

Removing MP 1.3.49, installing 1.3.44 and MP can connect to the PixRacer via ESP8266.
The problem with MP is ESP8266 connection, not PixRacer (via USB) connection in general.

On the github page, I’ve provided also logs from both MP 1.3.44 (which works) and MP 1.3.45 (which does not) and they are radically different on the same Windows installation, so I do not think that it is an issue with Windows (at least on network drivers level).

can you try disabling the firewall?

The (Windows) firewall is always disabled and the AVAST Antivirus also disabled for the whole session.

ive had a look at the difference between 1.3.49 and 1.3.44. and there is nothing

Thank you for taking the time to look at this.

Is there anything else that I can send you in order to understand what is going on?
Firewall disabled, Antivirus disabled (just antivirus, I have not installed the personal firewall option), Windows up-to-date (including .NET updates).
USB and MavLink connection (via a clone 3DR 433MHz telemetry module) work all the time, the WiFi option does not.

Maybe what I write is stupid but is MP 1.3.44 using the same add-on drivers (the ones that the MP installer installs during setup) with MP 1.3.49? I am just grasping at straws trying to find out why WiFi is not working.

I do not have a pre-Windows 10 installation anymore to test also, sorry.

i just tested here again, and cant fault the connection to a pixracer via wifi.

do you have wireshark or similar installed to see whats going on?

No but I will get it and use it to capture network information.
Will report back.

also, how old is your esp8266 firmware?

It is v 1.1.1 downloaded from this page (prebuilt binaries): https://pixhawk.org/peripherals/8266

what does show?

@Michael_Oborne there is another issue related to Pixracer and ESP8266 here: I2C Maxbotix range finder on Pixracer

same question as above. what does that url show? is data making it to the esp8266?

I’ll have to check,
On this particular issue, there is no rangefinder values shown on display when PixRacer is connected through UDP with the ESP8266 but when connecting using USB or Telemetry, it shows values.