Mission Planner Wizard behaving crazy. Is this normal?


I tried to install and run Mission Planner (MP) and this is what happened:

  1. It installed everything including drivers and asked me if I want to use the setup wizard. I said yes.

  2. It asked me to plug in my Pixhawk 4 but then this happened:


  1. It said that the connection failed, so I was sad but then I noticed this happening:


  1. I had no idea what that was that it managed to make work. So I clicked on that “Details” of the connection failed error and got this:


  1. As the wizard seemed to start working even after those initial errors. I started noticing these problems where no matter what I did, it wouldn’t let me see the full texts,


  1. I went ahead anyway but ran into similar troubles along with a strange one where the wizard wouldn’t accept me typing in any damn number at all! Firstly, as you will see in the pictures, it’s difficult to see what I am typing in because of that grey thing over the field. On top of that, I’ve typed in 2200 mAh (without the mAh part) in many different ways just to make it work. It simply will not accept ANY input.

  1. After all of that, surprisingly, it was kinda sorta working. I could see the sensor readings and my approximate location on the map.

I’m confused as to what’s going on. What’s the thing that happened with the driver and COM port? Why does the wizard GUI not show me all the texts or even let me enter ANY value for the battery?

I’d like a more legitimate and error free setup.

this is because the parameter names have changed. Don’t use the wizard just click through the items in the mandatory hardware tab.

1 Like

could be Microsoft Visual c++ . I had the same error but after installing Microsoft Visual c++ the problem was gone. https://www.itechtics.com/microsoft-visual-c-redistributable-versions-direct-download-links/ . check your chipset drivers and directx or check if any other program is using this com port. i hope this helps good luck.

Assuming there is a process to do so manually, I’d like to open Mission Planner now and erase all settings/setup from that wizard and start again and do it manually like you said.

I checked in my programs list and found this:


It looks like I already have Microsoft Visual C++ installed.

I’ll try to find what else on this machine might be using this COM port.


you could try qgroundcontrol and see if that connect normal http://qgroundcontrol.com/downloads/

Hey Michael,

Thanks for the suggestion. However, the truth is that I started with QGC, not Mission Planner.

QGC won’t even recognise my Pixhawk 4. I’ve posted on this forum about this problem and I’m still seeking help. Here’s the link to that: http://discuss.px4.io/t/pixhawk-4-device-driver-not-found/

try it on different pc? or qgroundcontrol android apk on your Phone or tablet (telemetry).if that doesn’t work you could try to reset the pixhawk. How to reset pixhawk?

good luck

The issue is that I have to find a way to make it work with my PC. It just has to work! Trying to source another computer for this just ads a lot of major inconveniences for my work. :frowning:

I have asked for the help with the driver issue on the QGC gitter channel but nothing they’ve suggested has solved this problem so far.

Do you know where I could download the specific driver file that’s missing? It seems to me like manually installing that one driver file would make QGC work with my Pixhawk 4 as that’s the only part of the system that’s not working right now (due to the obvious lack of that driver).

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers download the 1 for your OS. you can find the drivers in de folder 32/64 for manually install in device manager.

1 Like


UPDATE: QGC notified me of an update release so I downloaded that and installed it. Now it looks like it finally recognised my Pixhawk :smiley: Thanks for all the help anyway. I might need to use MP too :slight_smile:

By the way, do you know how to disconnect the flight controller from QGC like one does in Mission Planner? There seems to be no connect/disconnect button.

1 Like

Nice! im not sure if there is any disconnect option. i think shutting down QGC is the only way (not sure)