Mission Planner Sitl Bad Ahrs

Hello everyone,
I’m using Sitl and i keep unhealthy AHRS error. Sometimes this error disappears but drone do not take off in sitl

You don’t have a Frame Class configured. Says it right there on the messages screen.

1 Like

How can i configure Frame Class. I don not know

You can Google “ardupilot frame class” and read all about it from the Wiki.

I found thank you but it isn’t working again

What does the mission you wrote to the Sim Flight Controller look like?

I tried basic mission in Plan

I suppose that should work. The Frame Class problem was strange did you change other parameters from default?

Previously My DISARM_DELAY was 10 seconds. I changed this and haven’t changed anything else

Hmm. Because the default value for Frame Class is Quad (1) that’s why I asked thinking others were changed. What version of Mission Planner?


You need to raise the throttle above 50% to trigger a take off. You can use joystick.

You probably can also turn it of in the params somewhere.

OK, same one I’m running. Clearly you have started the Mission from the takeoff command shown in the messages screen. You are starting this from the the Actions screen with the “Do Action” “Mission Start”?

Perhaps you should “reset to default” from the Full Parameter Screen and start over. Typically SITL just works with defaults.

I tried what you wrote but it didn’t work or I couldn’t .Thank you for everything

or arm, then rightclick the map in flight data and click takeoff

it doesn’t work sorry