Mission Planner on Ubuntu 22.04

Anyone have any problems executing mission planner on Ubuntu 22.04? I’ve tried copying instructions from this thread, but it still doesn’t seem to play nice with the latest release.

ive just made a change in beta, that i hope will fix this issue

1 Like

Awesome; I’ll give it a try.

Thanks!

@Michael_Oborne
(MP-on Linux)
Just wanted to provide some feedback regarding the beta version:

The good:


The Log Browser window has now buttons and drop-down list accessible. :grinning:

The unfortunate:


Quick view window no longer displaying correctly. Unsupported font?

On a different note: In the stable version there appears to be an issue connecting to Pixhawk6x (via USB). Whilst manually selecting the USB port allows regular connection, when trying to upload firmware a message comes up “No connection found” (or something of that nature) - Hence firmware upload to Pixhawk 6X currently not possible.
I assume this is just due to a lack of support for this FC in current stable version?

Thanks

I’m having a similar issue with the display of Quick View. I’m getting nothing in the box. I’ve also noted that the GPS HDOP and Sat count is missing.

I’ve tried both build 1.3.8271.10556 and 1.3.8266.5307.

Just updated to 1.3.8278.8394 and still no data in the quick tab or HDOP/Sat Count on the map screen…

As it happens so did I.
But I do have data in quick view tap using Ubuntu 20.04 (Just no data showing as not connected to drone right now)
…but appears someone got a good sense of humour. :+1:

temo@MacBookPro:~/MissionPlanner-1.3.73$ ./MissionPlanner.exe
If your error is about Microsoft.DirectX.DirectInput, please install the latest directx redist from here http://www.microsoft.com/en-us/download/details.aspx?id=35 


Debug under mono    MONO_LOG_LEVEL=debug mono MissionPlanner.exe
To fix any filename case issues under mono use    export MONO_IOMAP=drive:case
Data Dir /home/temo/Mission Planner/
Log Dir /home/temo/Mission Planner/logs
Running Dir /home/temo/MissionPlanner-1.3.73/
User Data Dir /home/temo/Mission Planner/
at MissionPlanner.exe.Program.Main  (IL offset: 0x1)
at MissionPlanner.exe.Program.Start  (IL offset: 0x107)
at System.Windows.Forms.dll.Application.EnableVisualStyles  (IL offset: 0x6)
Message: The type initializer for 'System.Windows.Forms.XplatUI' threw an exception.
CustomMessageBox.Show
exception inside UnhandledException handler: (null) assembly:/usr/lib/mono/4.5/mscorlib.dll type:Exception member:(null)

[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Windows.Forms.XplatUI' threw an exception. ---> System.MissingMethodException: Method not found: int Mono.Unix.Native.Syscall.fcntl(int,Mono.Unix.Native.FcntlCommand,int)
  at System.Windows.Forms.XplatUIX11..ctor () [0x00077] in <28e46de2d20c496895000ef0abfc2106>:0 
  at System.Windows.Forms.XplatUIX11.GetInstance () [0x00019] in <28e46de2d20c496895000ef0abfc2106>:0 
  at System.Windows.Forms.XplatUI..cctor () [0x000c0] in <28e46de2d20c496895000ef0abfc2106>:0 
   --- End of inner exception stack trace ---
  at System.Windows.Forms.Application.EnableVisualStyles () [0x00006] in <28e46de2d20c496895000ef0abfc2106>:0 
  at MissionPlanner.Program.Start (System.String[] args) [0x00107] in <231ad899de864fa081cf231efbd9281c>:0 
  at MissionPlanner.Program.Main (System.String[] args) [0x00001] in <231ad899de864fa081cf231efbd9281c>:0 
temo@MacBookPro:~/MissionPlanner-1.3.73$ 

I am not able to run Mission Planner I tried the stable verison 1.3.77. I am running Ubuntu 20.04 on a MacBook Pro Late 2011. Any guidance would be appreciated.

Have you installed the full “mono” package?
Won’t work without it.

Yes I have installed all dependencies and mono-complete as the tutorial suggested.

Have you got all the directories correct? That text is showing .73 not .77.

1 Like

Yes, Allister is correct.
It shows .73. - Downloaded old version by accident?
That version was only able to run in Ubuntu using “Wine”
This however is not required in later versions.
In fact if you have Wine installed you need to make sure to start MP with Mono instead.

I had the same issue with .77. I downgrade since the tutorial I followed showed .73. I will try .77 again to make sure the output is the same.

All working thanks guys.

The problem was the version I was running. Initially I ran MissionPlanner-stable.zip that was .77 and it did not work. Then I downgraded to MissionPlanner-1.3.73.zip and that didn’t work either, I had followed a tutorial for the raspberry pi install thinking it would be similar to ubuntu. Now I installed MissionPlanner-latest.zip and the first run it got hung up but the second run it executed perfectly. I followed this tutorial. Hope this helps other people, again thank you.

1 Like