[Install Mission Planner ou APM] ubuntu 22.04

For two months I have been trying to install apmplanner or missionplanner on my pc. I can’t. I’m reviving the topic sorry.

I tested all the versions for these two software. I tried to install different version of Qt (5.9…). I tried to go through mono (for MPlanner) nothing happens I have core dump …

Can you help me to have a stable tool, anyofthem ? Please.Otherwise I will abandon the attempt to build a drone myself :frowning:

Linux  5.15.0-58-generic #64-Ubuntu SMP Thu Jan 5 11:43:13 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux
root@boussole:/etc/apt# uname -a
Linux boussole 5.15.0-58-generic #64-Ubuntu SMP Thu Jan 5 11:43:13 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux
root@boussole:/etc/apt# mono --version
Mono JIT compiler version (tarball Tue Jun 14 22:35:00 UTC 2022)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
	TLS:           __thread
	SIGSEGV:       altstack
	Notifications: epoll
	Architecture:  amd64
	Disabled:      none
	Misc:          softdebug 
	Interpreter:   yes
	LLVM:          yes(610)
	Suspend:       hybrid
	GC:            sgen (concurrent by default)

When i try to install firmware on my APM2.8 with MissionP:

	  at MissionPlanner.Common:MessageShowAgain <0x010c3>
	  at <>c__DisplayClass114_0:<doConnect>b__3 <0x0049f>
	  at System.Threading.Tasks.Task:InnerInvoke <0x00063>
	  at System.Threading.Tasks.Task:Execute <0x00037>
	  at System.Threading.Tasks.Task:ExecutionContextCallback <0x0005f>
	  at System.Threading.ExecutionContext:RunInternal <0x001a7>
	  at System.Threading.ExecutionContext:Run <0x00042>
	  at System.Threading.Tasks.Task:ExecuteWithThreadLocal <0x000f6>
	  at System.Threading.Tasks.Task:ExecuteEntry <0x000e8>
	  at System.Threading.Tasks.Task:System.Threading.IThreadPoolWorkItem.ExecuteWorkItem <0x00026>
	  at System.Threading.ThreadPoolWorkQueue:Dispatch <0x0028a>
	  at System.Threading._ThreadPoolWaitCallback:PerformWaitCallback <0x0001c>
	  at <Module>:runtime_invoke_bool <0x00086>
Abandon (core dumped)

I try this: ubuntu22

I try to compile with some versions of QT, example: 5.9.3

Many errors generated.
With other versions QT, there are some others errors… :frowning:

I create a vm (on virtualbox) under ubuntu20… the IHM is running…

The APM flight controller is so old you will struggle to get versions of ground control software to work with it.

Probably best to get a supported flight controller, there is many. Some are actually cheaper than buying an old APM from the cheap chinese web sites that push them.

And use QGroundControl on linux, using the latest install instructions for the appimage

In the past “Mono” was required to get MP working in Ubuntu.
The important thing is to install the full version, not a trimmed down version.

For that reason I find QGroundControl easier to install.
…But I still have both installed regardless of the extra hassle. In this way can use the best features from both.

Ahh, yeah, as Shawn said. Don’t bother with the old APM.
( A bit like taking an old steam train to a F1 race) :wink: