Mission Planner on Linux - latest observation

latest beta
add

{
“Label”: “Mavlink SITL port”,
“Enabled”: true,
“Port”: 5760,
“Protocol”: 0,
“Format”: 0,
“Direction”: 1,
“ConfigString”: “127.0.0.1”
},

1 Like

Thank you @Michael_Oborne
Unfortunately BETA Update is currently not possible (I just reported).

That’s the log:
INFO MissionPlanner.Utilities.Update - Newer File zh-tw/MissionPlanner.resources.dll
INFO MissionPlanner.Utilities.Update - already got new File zh-tw/MissionPlanner.resources.dll
INFO MissionPlanner.Utilities.Update - Newer File zh-tw/ZedGraph.resources.dll
INFO MissionPlanner.Utilities.Update - already got new File zh-tw/ZedGraph.resources.dll
INFO MissionPlanner.Utilities.Update - Starting new process: mono with “/home/willy/MissionPlannerCode/Updater.exe” “/home/willy/MissionPlannerCode/MissionPlanner.exe”
ERROR MissionPlanner.Utilities.Update - Update Failed
System.ComponentModel.Win32Exception (0x80004005): Cannot find the specified file
at System.Diagnostics.Process.StartWithShellExecuteEx (System.Diagnostics.ProcessStartInfo startInfo) [0x00102] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
at System.Diagnostics.Process.Start () [0x00032] in <9c6e2cb7ddd8473fa420642ddcf7ce48>:0
at (wrapper remoting-invoke-with-check) System.Diagnostics.Process.Start()
at MissionPlanner.Utilities.Update.updateCheckMain (MissionPlanner.Utilities.IProgressReporterDialogue frmProgressReporter) [0x00219] in :0
CustomMessageBox.Show
CustomMessageBox thread calling ProgressReporterDialogue Background thread
CustomMessageBox thread running invoke Base Thread

It seems that there happened a “partial-beta-update” that fixed all that?!?
Now UDP via 14550 is working again as usual:

Edit: Sorry, that happened just one time - no idea why. I will investigate that and hope to find out.

I tried to start $ mono Updater.exe manually and it seems the update finished correctly.

With port 5762 the AutoConnect works fine:

Thank you again @Michael_Oborne - very great job you are doing here.
I’m so happy that I can use MissionPlanner after the switch to Ubuntu.

Dear @Michael_Oborne

I liked missionplanner on raspberry pi 4 at first whith mono, after already connecting the drone with a navio2 + raspberry pi 4 too, it got slow.
Install Manjaro 21 minimal 64 Bits and add LXQT as desktop on the raspberry pi, install Qgroundcontrol and Mission Planner, it worked better than with raspbian OS.

In Manjaro with AUR you find everything:
qgroundcontrol and mission planner.

installing qgroundcontrol and mission planner in manjaro is child’s play.

You install everything with just 2 clicks

Hi,
after upgrading to MP 1.3.75 (using Mono) I now have a problem whereby when trying to connect via TCP the GS no longer responds.
It appears to be still operational but not responding to “Cancel” or not closing full window. Yet CPU usage appears to be normal.
Only options of closing MP are: Reboot, Log off / Log on, or by killing process in System Monitor.
System in use:
Kubuntu 20.04
KDE Plasma 5.18.5
Kernel 5.4.0.80

The interesting thing is that TCP connection was working fine in MP 1.3.74

In an unrelated matter:
When reviewing a Dataflash-Log the buttons for various options I.e. displaying/removing status messages, errors, events,… will be hidden once the Data Table is activated. Unfortunately this will not reset when MP is re-started.
Also unable to un-check the Data Table option as this is also gone. - Hence stuck with this display option until re-install or version upgrade.
This has been already been observed in version 1.3.74
(Could this be linked to my specific screen resolution -1920x1080 ?)

…Unfortunately re-sizing the table or the chart doesn’t fix it as gap between the two remains the same no matter what. (hence buttons not visible)

Ubuntu18.04 system, loaded mono and run MP…this is what I get

any suggestions?

Did you pull down the dependencies (ie all the mono components you need or mono-complete)?

What mono version are you using. Normally I don’t use the Ubuntu version

Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1ubuntu1)

just installed it from the Ubuntu software app…which should give latest and greatest…checked its mono-complete

the latest is v6 +
check here
https://www.mono-project.com/download/stable/#download-lin

I’ve got a script somewhere that does the right things (arm and x64 variants)

thanks …installing that directly from the mono site allows it to open fully…and it will connect, sometimes, to an autopilot attached via USB, but only at baud rates 56.7K and below…attempting at higher rates, give a “too many files open error”…MAVftp works sometimes also to get the params upon opening…but not always…in addition, you cannot resize the DATA left side panels…you can detach the HUD, however, and resize it…

I would like to find a reliable installation and then write a guide in the WIKI for that including the limitations

Here’s my script. Won’t fix the issue you’re having, but does make installing MP a little easier.
MP_Ubuntu_Installer.sh.txt (2.2 KB)

when you open MP wait a short time before connecting. im not sure why this is happening yet, but most likerly to do with the tlog scanning at startup. Or increase the max open files allow in the kernel

:rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl:

Joystick soon… a year ago

Hi, I have used joystick too. and in a setup page i do not have any problem and stick work properly and I can enable it but in a radio calibration window the bars did not move at all. do you have any suggestion? the joystick is logitech x56.

Hi,
I was just wondering if there has been any update / progress on display issues using MP under Linux?
(Using latest MP and just updated Mono to 6.12.0.182 - also running KUbuntu 20.04 using KDE Plasma 5.18.8 Kernel 5.4.0-122)

Just to recap:
Using Mono main display is OK
a) However, when trying to open a log or file an error message appears - workaround: Having to wait about half a minute then it will eventually work.
b) In the log review screen the various tick boxes and buttons in the middle are not accessible - hence can’t use any of those functions / options.

Main Screen working fine :+1:

Using WINE the following issue appears:

So whichever system I use I will run into some trouble one way or the other.
So for the past year been just using a workaround by using MONO for regular flight operations and WINE for log analysis and certain other task.