Servers by jDrones

Mission Planner hangs on "Getting params" when connecting throught TBS Crossfire Bluetooth Mavlink

(Luis Miguel González Fernández) #1

Hi.

I’m trying to get mavlink telemetry in my mission planner runing in my notebook. To get this i have configured TBS Corssfire Transmiter Bluetooth to “MAVLINK” and feed mavlink rx/tx configured outputs in my receivers (diversity receiver an nano diversity receiver) from telemetry outputs of my Pixhawk 2.1 and Matek F405-Wing (1st runing arducopter and 2nd runing arduplane).

I can connect via bluetooth to Crossfire TX, but mission planner stucks while “Getting params” dialog box is continuosly shown. Mission planner receive some kind of telemetry data cause if i move the hexacopter or the flyingwing the mission planner’s hud shows these movements, almost with 1 second lag but getting updated.

All Crossfire devices (TX and RXs) all updated to latest firmware 2.95.

I need mavlink throught bluetooth funcionality up and runing at its best.

I can’t afford to get expensive RF900 modules for all my UAVs in order to get good mavlink bidireccional telemetry.

Thanks in advance.

Miguel.

(Andras Schaffer) #2

Sorry, but what you get is what you paid for. TBS is NOT a telemetry radio, but a Hobbyist RC radio which happens to have a limited telemetry support.

Check with an android tablet and QGC, windows is notorious for bluetooth driver issues…but don’r except too much…

(basti) #3

@qkidamon i’m not exactly familiar with the crossfire (DL user here), but imho those symptoms might be due to port setting mismatches or bandwidth overflow. double check you’ve set your all baudrates to match incl. BT-settings. afaik the crossfire doesn’t use hw flow ctrl which is a non-issue on the Matek wing, but might require adjustments on the pixhawk’s serial port settings.

(Kenny Trussell) #4

I have a similar but not identical problem with a Skydroid M12L transmitter which has Bluetooth and USB connectivity to a PC. I’m running Mission Planner. If you look at the Stats while connected, you will likely see many dropped packets. This thread that I started about my issue may be a little help: Errors uploading missions.

I have not solved my issue either.

(Stefan Arbes) #5

I‘m using a Raspberry Pi0 as a simple gateway between TBS Crossfire Bluetooth and Wifi. With this simple solution, Mission Planner can connect simply with UDP to Mavproxy, running on the Pi.

If you want, I can post the short shell script that is executed on startup. It connects the pi to Crossfire’s bluetooth, waits till the connection is established an then launches Mavproxy. Mavlink-routerd or Cmavnode should do the job well too.

Despite of Andras oppinion, this solution is running stable and sufficient for years here under commercial circumstances. But most of my missions are in the range up to 1km or so, not further.

Best,
Stefan

(Romeo E) #6

Are you using Chibios on the Pixhawk? If not do it, it works a lot faster, I have also RC over mavlink and it works without problem.

(Luis Miguel González Fernández) #7

Many thanks for your quick and great answers, guys.

I`m aware of the fact that i can’t expect same quality and reliability from CrossFire Bluetooth Mavlink bridge as from a SIK pro module as RF900s. Thank you very much anyway Andras.

I will check hardware flow control setup of the telemetry port in the Pixhawk Telem port connected to CrossFire RX. Thank you very much Basti.

Thank you very much Kenny. I will take a look to the topic you talk about in your post. I whish it could be of utility for us and other people.

Hi Stefan. I have a PI0 Wifi and should be awesome test your configuratión. Thanks a lot.

Anyway, i have made a support ticket in TBS and as first indication they recomend me to update all Crossfire devices to firmware versión 3.0 as 2.95 has been retired cause many issues have been detected. They suggest to use only 57600 baud rate for telemetry and Bluetooth. I will give a try to version 3.0 and give you feedback.

Hi Romeo_E. Yes, i’m using Chibios in th Cube Black too. Thanks anyway.

Thanks again.

(Luis Miguel González Fernández) #8

Hi guys.

No luck.

All Crossfire devices updated to firmwares version 3.0. Baud rate fixed to 57600 and SR1 ardupilot variables set with values specified in page 38 of https://www.team-blacksheep.com/tbs-crossfire-manual.pdf .

Same result with Mission Planner and with QGroundControl on my smartphone too.

I’m about to show white flag. :cold_sweat::cold_sweat::cold_sweat:

(Kenny Trussell) #9

Stefan,
I would be interested in your script. I may use something like that in my setup eventually.
Thanks,
Kenny

(Luis Miguel González Fernández) #10

Hi Stefan.
I would like to test your configuratión in my Raspberry Pi0 W.
Have you made any tutorial or guide.

Thanks.

(Andras Schaffer) #11

I don’t want to be accused of TBS bashing, just want to add one important note here. TBS and Frsky R9 systems are ASYMMETRICAL regarding to transmitted radio output. There is NO power amplifier in the receivers, so if you want to use if for telemetry, your range will limited by the 25/100mW power of the receiver tx side, and for that range your can have a cheap 100mW SikRadio for REAL telemetry…

(Luis Miguel González Fernández) #12

Thanks again Andras. Only for this time i’m going 1 step faster. I’ve just ordered one of this:

https://www.banggood.com/Holybro-433Mhz-915Mhz-500mW-Transceiver-Radio-Telemetry-Set-V3-for-PIXHawk-4-Flight-Controller-p-1325025.html?rmmds=myorder&ID=529053&cur_warehouse=CN .

.

Do you think that, even assuming de fact that these 500mw are not totally real, with a direccional patch ground antenna and a free line of sight… a range close to at less 1KM could be reached ?

You are right at the end. A work is always better done using the right tools designed for that specific work.

Maybe next step will be a couple of RFD866x modules.

Thanks a lot.

Miguel.

(Andras Schaffer) #13

With 500mW and with a directional antenna, at 64kbit speed you can easily have 2-3Km. The main issue with Sik radios that the RF receiver is deaf as my granny, so you have to compensate with rf output power and good antennas.

Just for comparison, I flew 12km with an rfd868x, only with the normal rubber ducky omni antennas and at 200m height. When I turned back at 12km I had 0 lost packets, 100% link quality. (the reason for turning back was end of permitted airspace and battery)

(Freddie Sherratt) #14

With TBS Crossfire we had the same issue connection issue.

For us, it was the telemetry uplink not working and consequently, the request parameters message not being received by the aircraft. I believe it was fixed by a factory reset of the transmitter unit.

(Luis Miguel González Fernández) #15

Thanks. i will try it.
Miguel.

(Luis Miguel González Fernández) #16

Hi Andras. Do you know if rfd868x can wor wihtout RTS and CTS signals wired from FC ?
I’m thinking mainly in my Matek F405-Wing.

Thanks.

(Andras Schaffer) #17

yes, tx/rx only is the recommended configuration

(Luis Miguel González Fernández) #18

Reset to factory default done and IT RUNS … but with an almost 70% of mavlink packet loss. No reliability at all.

Sigh.

(Freddie Sherratt) #19

That’s odd, normally i a very good telemetry link.

Probably worth checking your tx settings after the reset. Just incase something unexpected change like operating frequency.

(Luis Miguel González Fernández) #20

Hi Freddie.

I’ve have replicated all setup (TX and RX) after reset all Crossfire devices.

Is in QGroundControl’s Settings->Mavlink tab where i see this tremendous loss of packets. Maybe i should check it in Mission Planner too but i don’t know where or how to doit (¿¿¿ Console ???).

Thanks.