Mission Planner GStreamer Source not working on Windows X86 Laptop

Hi I am using an older Windows X86 laptop as my GCS running Mission Planner and I am trying to get GStreamer working as the HUD. I am just trying to get the default source to test it: videotestsrc ! video/x-raw, width=1280, height=720,framerate=25/1 ! clockoverlay ! videoconvert ! video/x-raw,format=BGRA ! appsink name=outsink, but it errors saying that it is missing DLL’s

error

Looking at the version of Gstreamer that is uploaded by Mission planner it looks like it is the X86_64 version, but to operate on this laptop I think I need the X86 version - is it possible to force Mission Planner to install the X86 version instead of the X86_64 version? I tried overwriting the installed version with the X86 version but it does not seem to like that.

I have loaded Gstreamer V1.12.4 X86 and can run it OK as a standalone application but if I try to run the version of Gstreamer installed by Mission Planner directly from its directory it says that this version is not compatible with this operating system,

I am running the latest version of Mission Planner and Windows 10 on an X86 Intel Dell Laptop.

Your help would be appreciated.

currently only x64 is packaged for use with mission planner.
I would suggest upgrading.

you could try placing gstreamer x86 in C:\ProgramData\Mission Planner\gstreamer

Thanks for your reply Michael, I tried putting the X86 version of gstreamer in the MP directory (had to also change the directory name from X86 to X86_64) but it still does not want to quite work. I get an error in the MP log: “INFO MissionPlanner.Utilities.GStreamer - failed gst_app_sink_try_pull_sample (:0) [gstreamer]” and then MP dies.

Any other suggestions would be appreciated.