Mission Planner - GPS glitching?

I calibrated my quadcopter in outdoor environment (pixhawk, neo 8n gps) but for some reason I see my copter changing its position when its staying idle in DISARM mode. It’s just sitting there but I think the GPS is glitching.

I used a different GPS and calibrated it again but still its glitching on its own. I didn’t take a test flight to avoid any crashes. Any idea what’s going on?

The image above is all under disarm mode (idle). Why is that?

What’s glitching radius? It seems like really minimal. Can you post about satcount and gpshdop?

please set LOG_DISARMED=1 then send log file

satcount is about 14 and gpshdop is no less than 1.5

That’s not glitching thats just standard GPS variance.
As it locks in to more sats for a longer period you will get less and less movement.

Sat count is NOT a measure of accuracy, and HDOP is only one of many indicators of current position accuracy.

@hosein_gh asked for a .bin file from the flight controller!
Can you upload one please so we can give a more definitive answer.

How long do leave the copter to get a lock?
How clear a view of the sky do you have?

I did a test flight today. The copter took a stable takeoff but during hover it was circling around. Not aggressively but slowly. I have attached my telemetry logs. I am getting an error when I try to download DataFlash logs:

Getting list of log files...
Error:System.TimeoutException: Timeout on read - GetLogEntry
   at MissionPlanner.MAVLinkInterface.GetLogEntry(UInt16 startno, UInt16 endno)
   at MissionPlanner.MAVLinkInterface.GetLogList()
   at MissionPlanner.Log.LogDownloadMavLink.<LoadLogList>b__12_0()

telemetry_logs.zip (872.2 KB)

Here are my compass offsets

unfortunately telemetry logs will not help too much please check these item for log downloading problem
1-update your mission planner to latest version
2-check sdcard on your pixhawk
3-check log bitmask of your fc

00000292.zip (986.7 KB)

I uploaded my bin file. Please sir kindly take a look.

about your GPS your HDOP is low enough, also horzontal and vertical accuracy was 60 to 80 cm while flight totally your GPS status was good

about circling around or yawing your mag2 is noisy so its better to turn it off

your mag1 is OK

by looking at ATT values in log your yaw and DesYaw is different sometimes i think its because of noise on mag2 (try to keep away high ampere wires from your mags totally)

also check your z vibration its acceptable but a little bit high
high z vibration cloud affect EKF measurement

And do you autotuned this craft ?

Can you tell me where do I turn off mag2? I am a little new to this tool.

No I did not auto tune this. Should I do it? If so, how?

Done all of these steps in this link one by one

By tuning your craft it might solve your yaw problem

In this page uncheck mag2

Its not circling via yaw, the head of pixhawk is in the same direction. It’s circling via roll and pitch (keeping the orientation of pixhawk same)

Then there is another problem. In the graph of yaw Hosien posted above it seems to show a very rapid Yaw spin but I don’t believe the craft can spin this fast and you are reporting it’s not spinning at all. In one case it shows a full spin in 200msec which isn’t possible.

The motor outputs don’t indicate rapid yaw occurring either.

at all i think first its better to finish tuning process
a not tuned craft could have many problems

Okay. I unchecked Compass #2 and ran a test flight again. This time the flight was pretty stable :slight_smile:

Though the throttle stick takes a lot of delay when changing altitude. But the roll, pitch and yaw work great. I have uploaded my logs again. Do you see any anomaly now?

P.S. Thanks a lot sir! Logs can really help when diagnosing flight problems.