Mission planner displaying 0 battery voltage

Pixhawk cube black
Mauch current sensor
Mauch PC3v3
6S lipo 10000 mAh
Screenshot (29)

Maybe listing the related parameters would help us help you.
Or you can save all parameters to a file and upload that here

I can upload a file but I cant remember how to create one.

Full parameter list, save to file at top right

Multirotor.param (19.6 KB)

I dont see anything wrong with your parameters for a Cube Black so far.
How have you got the Power Cube and voltage/current sensor all wired up?
Maybe even a photo.

Battery plugs into the current sensor. Then the current sensor is soldered to a small PDB feeding the 4 ESC’s and the mauch power cube. Pretty straightforward, nothing complicated. Something else that might be related is that I had to update the here 2 compass/GPS after updating MP to 4.4.1. So maybe the update may have changed something?

Where do the signal wires from the current/voltage sensor go to?
Got a picture?

Im not able to provide a pic at the moment but they connect to the mauch power cube

Still cant figure this out. That measured battery voltage isnt right. The battery has a storage charge of 3.8v/cell.

Is everything wired like this diagram, except you might only have one battery and voltage/current sensor and no sensor hub ?


Correct. One battery, current sensor and the mauch power cube. Everythings wired exactly that way in the diagram minus the sensor hub.

What amps per volt and voltage divider values were you supplied?

What if you put in the exact measured battery voltage (not per cell) in the top field of that battery monitor screenshot you sent - what is the calced values then?

The amps per volt might be around 65, and voltage divider might be about 10

Well the measured voltage in the battery right now is 22.8. Now its showing a voltage but the problem is the battery isnt plugged into the drone and the voltage divider has changed.

Sorry, I dont understand - if you connect up the battery and measure it’s actual voltage - put that value into calibration step 1. Measured battery voltage
The 2. Battery voltage (calced) should be extremely similar to the actual battery voltage
and 3. voltage divider (calced) should show some reasonable value around about 10 or so

The mauch voltage/current sensors come with a bit of paper showing their factory calibrated amps per volt and voltage divider values - did you get that? and what are those values?

The divider value and the A/V values in this pic are the ones that came on the little piece of paper with the sensor.

OK, excellent.
So when you plug in a battery is there much difference between real voltage and that which is calced/shown by the flight controller?

If it’s still not right, check the wiring - lengthy sensor and BEC wires have proven to be an issue before, and these are all relying on that small black ground wire as a reference. (notice how the voltage/current sensor doesnt have a negative battery connected except for the tiny sensor wires)

I always reboot a flight controller after changing anything related to battery monitoring - that’s a bit radical but there are a couple of battery monitor related settings that only work after a reboot.

You will want these values too:


This is with the battery plugged in. Still not showing anything. I will try swapping out the signal cables.

OK, so dont change any of those parameters now - they look correct, except to adjust the additional parameters I specified.
Continue checking the wiring and connections.

Actually that screenshot - the current values indicate there is about 3.3volts on the current pin.
That’s very odd and you should measure the voltage on the Power1 current input and trace that wire back to where ever it goes.


Can you do a couple of photos?

The Power1 & 2 wires from the pixhawk all connect into the Mauch Power cube. I didnt really change anything the last time it worked. The Mauch cube has 2 5v outputs (for the pixhawk) and 1 12v output for other hardware.