Servers by jDrones

Mission Planner and override

I am using mission planner on an aircraft and i use a custom app on the same aircraft. MP and the app are on the groundstation pc.
The aircraft sends mavlink trough mavproxy to two different ports 14550 and 14551 on the pc, mp connects to 14550 and my python app to 14551.
On mission planner i use joystick, so it uses rc overrides. My app needs to override channel 7 but looks like MP doesn’t allow it. Whenever i try to override ch7 with my app, MP brings it back to zero, even if on the joystick in mission planner i set none to channel 7. I send my override every 1 second but MP brings it back immediately.
Is there a way to accomplish this without MP taking control?

@Michael_Oborne any idea?
Basicly i need to override ch7 that on mp joytick is set to zero, but doesn’t allow me to do it. Strange thing on simulator in mp it works.

If you need to maintain joystick control while also being able to override Ch7 from your app, then I think your only option might be to manage the entire joystick from your app. We have an ROS node that does something similar

I was trying to avoid managing the entire joystick to just override one channel.

In Mission Planner there is a ‘pass’ option you can assign to a channel in the joystick setup - have you tired this? I have not used this personally but it seems it may do what you want

Tried it, doesn’t work…

What about setting it to None for the RC controlled channels

Hello Michael, tried both, none and pass. They interfere with my override, they both bring it back as soon as i try to override it. Funny thing is that in MP simulator it works, not on real hardware.
Have any idea?

Just to try to help. I tested it on QGroundcontrol and it works as expected. Maybe when in joystick setup we select none or pass, in reality it doesn’t work.

It looks like you do not send UINT16 when “pass” or “none” is selected.

Edit: tested on UCGS and works there too.

@Michael_Oborne Did you have a chance to take a look?

Thanks,

Corrado

do you happen to have a tlog, of it working and not working?

i send 0, not UINT16
need to confirm whats working however

please try the latest beta mp, i will now send 65535 for the first 8 channels that are configured to None

Thank you very very much, i am out of office for a couple of days and i don’t know if I can test it. Anyway really thank you very much for this and for rtk.
I’ll give you a feedback as soon as i test it.

Hello Michael, override now works. The only odd thing is that when i override a channel with my mavlink command it doesn’t last the usual 3 seconds but stays a at the value of the last override. Maybe still something to look at.
For the rtk not working let me know if you want me to do any test.
Thanks

what are you trying to send to the rtk command?

ive tested here and is working fine. so need to see what you are trying to use

I did what you suggested:

/rtk http://user:password@IP:2101/mountpoint

Same address works fine inside rtk page

yep, and thats how i was testing as well.

are you using some kinda of vrs? or a fixed base?

I use a vrs from a payment service we subscribed too. Same we use every day inside rtk page

ok, so the issue is most likerly the location sent to the server then.

when using vrs, MP needs to send your current location to the server for it to start the vrs.

i was testing against a fixed base.

Servers by jDrones