Mission Planner and override

But in same position if i fill the rtk page it works, same everything.
Just trying to help.
Are you going to test against vrs or want me to test something else?

give it 10 mins, then grab the new beta. i think i found the issue.

Great thanks will let you know.
Really appreciate!!!

It works!!!
Thank you very very very much!!!

Hello @Michael_Oborne , i now have same problem you solved on channels 1-8, on channels higher than 8, 9-16 are overridden even if none or pass are selected. Can it be fixed as you did on first 8 channels please?

@Michael_Oborne did you have a chance to take a look at it?


are you running mavlink 2?
9+ only work on mavlink2

this is a ardupilot bug

Running mavlink2, everything works untill i enable joystick than even if set to none mp keeps sending 1500, only on channels >9.
If i disable joystick than everything works. It looks like it sends override even if set to none.

correct, its sends “0” for 9+, this is in the mavlink spec as being ok, however ardupilot doesn’t follow it currently

Ok, thanks, will wait for AP to correct it.

do you have a tlog of this happening?

Sorry for the late reply, we are closed until 24th august, will post one as soon as we reopen.



Here the tlog, thanks


@Michael_Oborne, hello Michael, did you have a chance to take a look by any chance?



@Michael_Oborne, please michael could you take a look at the problem with override? I am really in the need to use channels above ch8 but MP keeps overriding them, so in the end, for example ch10 i override it with my app but MP keeps bringing it to 1500, so the channels jumps up and down, between my override and MP. I tried everything on the channels and put none on joystick for the channels i use outside MP but to not avail.
To try to explain it: it looks like MP overrides all channels above ch8 (9-16) no matter what is the setting on the joystick. It looks like you do not pass 65000 to the channels to tell the system to leave them as they are if none is selected for those channels in joystick setup.

Thanks in advane


the tlog you posted i cant download. i wanted to confirm what MP is sending from that log

ok, after rereading your post, this is the first time you have mentioned there is another app in the mix. and is the reason this does not work.

MP send’s 0’s for these channels, which means dont use this. however if there is another app sending packets as well, then it will be flicking between your value, and dont use this value.

there is no way around this, as the 0’s are sent to say MP doesn’t have control of this channel. and it falls back to standard rc input.

im looking at adding another joystick axis to force the value high, just testing atm

there will be a new beta in a short time that adds UINT16_MAX as item in the axis drop down. this will make MP send the ignore this value item, as currently ardupilot doesn’t follow the spec. IE this is a workaround.

the downside is you will start using alot more bandwidth on your telemetry link