Missing GPIO Button BTN_ENABLE on F405 FCs

Good day, folks.

I need to use GPIO Button for arming on SpeedyBee F405-Wing but there is no BTN_ category in Full Parameter List so I cant go by this manual.

Current AP ver. is 4.4.4.
Tried AC 4.4.4, AP 4.2 and still missing.
Also tried on Matek F405-MiniTE - still missing.

I cant find any information that F405 is not supporting Button Function. Also I tried to recompile custom build of the FW and there is also no options for enabling or disabling this function.

Screenshot 2024-01-16 141001

The only F405 I have flying has that function available.

Try updating to the latest Mission Planner beta version. I can’t find a reason why this feature should be disabled, even on older hardware.

I use Button on my omnibusf405 boards so it should be there.

Yea, that’s the F405 board I have also.

Actually, I am on beta. Tried different MP versions and still missing. On the same time this list is shown on Pixhawk board or the Matek H743.

Guys, @rmackay9 @xfacta maybe you can suggest me something? Is that a FW compile bug? Or where should I dig at?


Thats not MP problem, I flashed F405-MiniTE with OmnibusF4 image and BTN_ENABLE parameter shows up. Of course, the FC is not working properly but now I find out that is FW related issue.

So what can I do with that, any thoughts?

Right here in the Hwdef.
Disable un-needed hardware drivers

One of a long list of disabled stuff to save flash.

1 Like

shouldnt this be added to the custom firmware options if its going to be disabled on some boards?

You would think so but as @cu-brick stated earlier it’s not shown in any field.
I see these boards have <1024 flash so even wimpier than some other F405’s I guess.

@tridge @rmackay9 any thought on this?

Oh, thank you a lot!

Thanks for the ping. I’ve added this to the Custom Builder Server issues list here.

1 Like

How did I miss that?! Very obvious, but I guess I didn’t just do the simplest search for “button.” Good to know.