Missing Arming Check bitmask

Latest MissionPlanner - Arming Check bitmap not working.
You can still set it manually by typing in a value.
Just posting here so everyone is aware, I’ve created this topic over at Cube Pilot

  1. Param regen no longer solve any issues with param names since the backend of parameter names storage is changed.
  2. To refresh param list, you have to delete the files from ProgramData/Mission Planner folder (this is a hidden folder in the system root on Windows. Then MP will redownload the definition files. (It seems that the files are fixed now)
  3. Param definition files are updated about once a week, if you are online.

I tried deleting selected files, graduating to deleting everything. MissionPlanner recreated missing files ok like all the .apm.pdef.xml files for example - but no difference.
Arming Check bitmask is about the only one I can find that doesn’t invoke the bitmask pop-up window.

Did you tried to click into the options field ?

EDIT: Disregard - I see there is new behavior that I find preferable, where there’s a second click required to get the popup bitmask window. Like Shawn has found, ARMING_CHECK does not trigger that option on my install, but all other bitmask params seem to function correctly.

Oddly, I’m not able to reproduce the issue.

Issue persists on my 1.3.8522.19145 install. All other bitmasks work correctly.

It usually doesn’t take long for a beta fix… Seems to be the same version as yours Yuri.

I just (beta) updated to that version before posting my last. I do not get the bitmask option for ARMING_CHECK.

Connecting to V4.5.0-dev? I can reproduce that.

Yes, using built-in SITL/latest.

Yea, there you have it. Connected a quad with Tridge’s Expo Version and see the same thing. And SITL.

1 Like

I uninstalled and reinstalled from Latest.msi and the Arming Check bitmask worked
Then I do beta updates and the Arming Check bitmask is broken.

1 Like

Any way to resolve this while still getting updates?

Wondering of someone can retest this for me please?

I’m now on Win11 (instead of Win10) and a new MissionPlanner install updated to 1.3.8543.1276 and the Arming Check bitmask is working OK

Interesting. I just updated to 1.3.8543.1276 (Win11), and ARMING_CHECK still fails to show the “Set Bitmask” option. All others seem to work fine.

I have not yet attempted a complete reinstall.

I just reinstalled and updated to 1.3.8553.12290 (Win10), still no bitmask checkboxes unfortunately.

What about Beta updates?

This is what I get with beta updates enabled.

Works for me with latest MP Beta and Copter V4.5.0-dev. It also works with Stable in SITL. I thought we ID’d the common denominator for this problem but apparently not.