MinimOSD reports "no MAV data"

MinimOSD running the latest “Extra” firmware and connected on Telem1 won’t receive any data 3 times out of 5 startups on Pixhawk and 3.2 RC14.

Was never doing this on 3.1.5. Any idea why? is there a timing delay now on this port TELEM1 causing the MinimOSD to “give up”??

thanks in advance.

Interesting, I’m having the same issue.

  • Pixhawk 3.2RC12 with MinimOSD-extra Copter 795
  • Did click the Enable OSD button in MP
  • Radio on Telem2 works fine
  • 3 wire connection from Telem1 to OSD, OSD LED is flashing but “no mav data”
  • Also not on Telem2 and/or with radio disconnected

There seems no need to tweak SR params, which didn’t help me anyway.

Got things working on my APM with 3.1 firmware. This is a new quad, so it might be me (though I wouldnt know where to look at this moment). Or it’s something else…?

Thanks in advance!

Ok, same issue with 3.1FW, looking at other causes now…

FYI, I didn’t have any issues running minimOSD with 3.1.5 but had the original firmware for the OSD and older char set. Upgraded Pixhawk to 3.2 RC14 and minimOSD displayed only “Update Charset”. Had to go to newer minimOSD firmware “Extra” but now, get this intermittent “no display”. Have to cycle power 4-5 times for it to finally recognize Mav link.

One more interesting thing is that the altitude displayed on the OSD doesn’t match what the telemetry is reporting. Telemetry being the correct one. Almost like the COMM protocol is different with 3.2 and the OSD hasn’t been updated in awhile.


I upgraded from rc13 to RC14 and discovered the same issue. I have to reboot the pixhawk a few times to get the MinimOSD to see the data. Not only that, yesterday I flew and noted that not all data was being displayed. Artifical horizon, AS, GS, and other important readings never showed any data. At this point I believe the DEVs need to look into this and update the firmward and character sets for release 3.2!

Hi I also am having a headache with my minimOSD showing a fantastic crisp and clear overlay on my fatshark camera and a groundstation screen 6’’ But! after trying several different OSD versions 1.9 ,2.0 Extra and a few versions of APM firmware from 3.0 to the latest 3.2 and also trying the serial mods from the wiki on OSD_Extras wiki I can get an Mavlink heartbeat on the screen but the data just is not forthcoming?
The Mission Planner readout on the startup terminal readout is saying that the MavLink Interface is requesting all the Data Streams but is saying "lost pkts new seqno 1 through to 255 bps 34 loss 14 left mem 78.166015"
and then repeats almost line for line except the last number changes for about 12 lines then gets another statement from the voice girl and then repeats again.and still the mavlink OSD keeps winking at me!!!
It’s taken me about a week of trolling the forums to get this OSD working with the 915Mhz 3DR radios on the split cable and I have run out of options.I was reading up on how to diagnose logs and thought I’d try to get some advice in this most battery consuming matter.
I so hope someone can come up with a fix as I have yet to fly this bird ! but I love the concept so much and it is brilliant that I can communicate with it from PC while I am looking where I’m flying and I’m getting a might excited at the thought of it being so close yet so far!.
Thanks to all who may be able to help me in this crises.posting.php?mode=reply&f=100&t=10270#
Cheers from JCinAuz

Gentleman, I too, have been having much difficulty getting mav data to show up with the MinimOSD and Pixhawk. I have been reading all the posts but nothing has worked for me.
I do see a conflict that may be significant. One post suggested turning off flow control for serial 2 port. (BRD_SR2_RTSCTS in advanced parameters) This was strongly discouraged in that forum, however some reported this worked for them. My question: In advanced parameters it states that for flow control to work the RTS and CTS pins must be connected, however the wicki for the MinimOSD only shows four of the six pins connected, no RTS or CTS. Honestly, no setting for the serial 2 flow control solved my problem. Is it worth wiring up the RTS and CTS pins? The MinimOSD board doesn’t label these pins. Any hope for flow control?

Ok, So I understand the MinimOSD board does not use flow control. I am able to access to board and flash or set configuration with my FTDI adapter, that has only four pin connection. I understand that the pin outs grn and blk are for the automatic reset after each command and not really necessary if you push the reset button immediately after each read /write command. At least I verified the boards not fried of bootloader corrupted. I still have no mav data from the Pixhawk serial 2. I have run thru every combination of sr2 settings and verified baud rate and mode for serial 2 with no results. Any help would be very appreciated. I see others have has this problem consistently over the past two years, so a solution is out there. Please help. Anyone?

I noted this issue on 3.2 and others that sometimes the Telem2 port does not startup. I used two different devices including the MinimOSD board and found this.
It seem to work more reliably with 3.3 that is in beta right now.


[quote=“iseries”]I noted this issue on 3.2 and others that sometimes the Telem2 port does not startup. I used two different devices including the MinimOSD board and found this.
It seem to work more reliably with 3.3 that is in beta right now.

This is interesting! I have MinimOSD on Telem 1 port and that works fine, but my radio modem is plugged into Telem 2 port and it takes about 3 power-ups of the craft before I see the radio modem initialize. I am running 3.3-rc5. So the issue still exists in even the newest rc version it appears!

Is this, in anyway, linked to the message I’m seeing “waiting for Mavlink heartbeats”. Damn thing was working last time I tried it. I’m thinking its somehow reset itself and I need to flash the board with the latest firmware…only problem is I’m running on APM on a mac. Any idea’s?

Yes, this is the problem. The Telem2 port does not startup on power up and consequently no heart beats are sent out.
It’s fixed by powering up the unit a couple of times.
I have another device connect to that port that is reading Mavlink data and it usually starts up on power up but sometime I have to kick it a few times.


Try setting the serial port flow control to disabled. It’s auto by default, but that doesn’t work with older firmware of the SiK radio (3DR Radio) … er1_rtscts

You can set this in the Full Parameter view of the planners

Ok. SO now I have some overlay. But the rest of the screen, where the overlay isn’t active, is covered in some kind of stripes making the viewing of the video almost impossible. These stripes are made up of non distinguishable characters. Its quite possible I’ve changed some parameters to cause this but I’ve no idea what. Been fiddling for hours and kind of lost track of what I’ve changed

Are your recommending turning off flow control for serial 1 and serial 2, or just shutting off serial 2 flow control. It was my understanding that the 3DR telemetry radio requires flow control? I’m willing to try anything on the bench but other forums seriously discouraged turning off flow control on serial 1 or 2, and a few have claimed serial 1 must have flow control enabled for the telemetry radio.

The older 3DR radio doesn’t even have the flow control lines connected. I would recommend setting the the parameter manually to what you have the 3DR radio set to, if it’s the newer design set it to ON. Setting it off will work in all cases for radio and APM.

If it’s not working, just don’t use auto detection.

I will give it a try tonight and let you know how it goes…
Thanks for the advice.

I too get either NO MAV Data or limited OSD (no voltage updates, level, compass, etc) with the current R800 and using my Pixhawk. I have the MinimOSD plugged into the Telem2 port with the 3DR radio plugged into Telem1 and working fine. Interestingly if I go all they way back to MinimOSD version 2.1 all works fine. I noticed that version 2.1 outputs status like “waiting for heartbeat” “requesting telemetry data” during bootup and then all starts working. Newer versions do not show this.

I find it difficult to believe that the MinimOSD team have abandoned the pixhawk since version 2.2 to present. There must be some required change for this to work but I have searched and find no mention of this.

Tmenet, Yea, I have not resolved this issue yet. I upgraded to 3.3, and that had no effect. turning off flow control had no effect. Wiring and cables have been verified, several times. Repeated restarts of the MinimOSD or the Pixhawk had no effect. Interesting that the MinimOSD firmware may have something to do with this. I currently have the MinimOSD Extra firmware installed. I’ll try anything.

In your case, if you have any information displayed at all, I would look at the specific SR2 settings. Perhaps experiment with them. The pixhawk wicki has some useful information in the full parameters list that might point you in a good direction.

I have been attempting to get mavlink data sent to a storm 32 gimbal controller on serial 4, also without any success.

Hquarter, try what I did and go back to minimOSD extra Version 2.1 . On my setup this version works perfectly. It won’t show up in the download section until you select “All Downloads” and click on “Search” The reason I stumbled into this is that my minim OSD is a Chinese clone and it worked fine with the version it came with (2.1) It wasn’t until I started updating the minimOSD that I started having problems.