Servers by jDrones

Mini Talon QuadPlane Conversion (cont.)

Just look on my youtube channel…the two videos preceding this one are two different MT standard quadplane setups…the older uses cross frame arms, the Dashware example was from a version with wing mounted arms…

Great project - congratulation Henry. I’m thinking of our discussion about the Quad / Tri efficiency comparison. Here are two films (18 months ago) about our 2.2 kg mini talon: (60 km/h = 38 mph):
a) https://vimeo.com/278828784
b) https://vimeo.com/292792793

Cheers!

It looks to be made under different conditions but I suspect that the QuadPlane version would have similar performance under either condition and only the Tilt-tricopter to be weaker in the wind.

yeah, my experience so far, but only if the wind exceeds the planes ability to progress with pitch forward …and use use VFWD_GAIN… Also, you have to have enough power and the tri is marginal…its hover is at 67%…The other quadplane flights were with 10mph wind or less…I used the same params in all Qplanes for limits of pitch…I just reviewed them and the QLOITER pitch limit was only 15 degs…whereas the limit in other VTOL modes is 30degs…I suspect that even this tri could have matched 15mph if I had used QSTAB instead of QLOITER and that the other quad versions would not have been able to station keep in that high wind unless I used forward gain…

yeah…nice…I really need to fix the chunks missing from my wings and make sure my wiring is streamlined…I have a lot of drag in my beater…once I am happy with tilt and setup, I am going to take one of my TWO spare MT kits and build a clean version…maybe even get it down to MarkQvales 1800g 5.5A cruiser :wink:

Just hover tested the addition of ballbearing to tilt mount and switch from TowerPro M90S to EXI D213F (another $8 servo, but my favorite)…big difference in yaw tune :yum:…could go back to default D and halved P and its 10X more solid and smooth… slop = need for LOTS of D and an less than ideal tune…well had to try…still an easy print and assembly…I will post it at some point…still want to try the ES09D servo

1 Like

IMG_20200409_104359_1

same picture, better resolution: https://drive.google.com/file/d/1Tkjy17WKzay8SBfF-Y5m_vEprT2dN_H7/view?usp=sharing

Ashley and I are stuck. We are attempting to get the software on the pixhawk, but can’t seem to connect all the pieces. Are we missing an intermediate receiver hub of sorts? We need to attach our SPM9746 DSMX Carbon Fuselage Remote Receiver to our PX4 2.4.6 and can’t seem to get it right.

the google link does not permit access…but this may help…https://ardupilot.org/plane/docs/common-pixhawk-overview.html

should attach to the DSM port in upper left area…whether the connectors are compatible is a different story, you may need to change the ones on the RX and GPS/Compass to fit the board connectors…

Ok, I tried a different link.
We will look at the list to double check what we have and our connectors. Thanks!

You should be able to find your information in the Spektrum RC Systems part of the WiKi. Like Henry said, there are several different connector styles for these receivers if the 3-pin connector doesn’t fit.

That being said, you really only need a USB cable connection to your PC/laptop to load software onto the Pixhawk via Mission Planner.
Loading Firmware

Good luck!

ok, so we unplugged everything, and are just working with the pixhawk and the USB connection. We plugged in the pixhawk (to the laptop) and got all 3 musical tones. We installed the firmware, but only got 2 musical tones at the end (instead of 3). So we tried wiping the firmware by installing firmware for the Rover and then tried reinstalling the firmware for the quadcopter. Still only 2 musical tones, not 3. Currently, plugging in the USB connection to the laptop gives us 2 musical tones as well. Is this making any sense? This youtube video is what we were going off of: https://www.youtube.com/watch?v=rRZw42Y27Jc

Those musical tones from the video are simply the USB port activating and deactivating. Install the buzzer to hear the real musicals tones coming from the Pixhawk. I would use the WiKi help below.
Loading Firmware

Thank you!
We successfully connected our Pixhawk and installed the firmware for the ArduQuadCopter. We are attempting to adjust the Parameters but all of the “Q_” params are missing. We can alter our parameters in a notepad file, but can’t seem to upload the file to the config/tuning with the “Q_” parameters. In fact, when we try to upload the .param file it says we are missing 393 parameters, even though they are there in the notepad file. Any idea as to how to get the params into the config/tuning tab of Mission Planner?

You have to set Q_ENABLE to 1 and re-boot the Pixhawk. Then the rest of the Q params will show up. Many of the features are like that when disabled to keep unwanted commands out.

We don’t have Q_ENABLE listed in the param list. There are no “Q_” params

Did you load APM Plane? (Don’t use Copter)

uh, no, we totally downloaded copter. We now have the “Q” params! Thanks a million!!!

1 Like

Finally Covid helps me to finish my vtol. Today I finished tunning the quad.

1 Like

Good job, cala!

Good luck on your next test!

1 Like
Servers by jDrones