MAVROS launch file for ArduPilot on Parrot Bebop

I followed the instructions to flash a Parrot Bebop with ArduCopter, and it seems like it worked. It does automatically connect to QGroundControl when I’m on the Bebop wifi network. But now I’d like to set up control from my laptop using ROS and MAVROS. I’ve also successfully made this connection with simulated arducopter. The missing link is just to connect MAVROS to the actual Bebop. I’ve tried several options for fcu_url in the mavros launch file, apm.launch, with the most recent one posted below. What do I need to put for fcu and gcs url?

	<arg name="fcu_url" default="udp://@" />
	<arg name="gcs_url" default="" />
	<arg name="tgt_system" default="1" />
	<arg name="tgt_component" default="1" />
	<arg name="log_output" default="screen" />
	<arg name="fcu_protocol" default="v2.0" />
	<arg name="respawn_mavros" default="false" />

	<include file="$(find mavros)/launch/node.launch">
		<arg name="pluginlists_yaml" value="$(find mavros)/launch/apm_pluginlists.yaml" />
		<arg name="config_yaml" value="$(find mavros)/launch/apm_config.yaml" />

		<arg name="fcu_url" value="$(arg fcu_url)" />
		<arg name="gcs_url" value="$(arg gcs_url)" />
		<arg name="tgt_system" value="$(arg tgt_system)" />
		<arg name="tgt_component" value="$(arg tgt_component)" />
		<arg name="log_output" value="$(arg log_output)" />
		<arg name="fcu_protocol" value="$(arg fcu_protocol)" />
		<arg name="respawn_mavros" value="$(arg respawn_mavros)" />

I updated the Bebop urls to and now I no longer get the udp0: network is unreachable error but MAVROS still does not connect to FCU. MAVROS outputs stop after
[ INFO] [1648906422.426452646]: MAVROS started. MY ID 1.240, TARGET ID 1.1

Found the solution! Fcu url needs to be:

<arg name="fcu_url" default="udp://:14550@:14570" />

Got the answer from a similar question on PX4 forum, but worked for me with ArduPilot :slight_smile: