Maverick 1.1.5 release - Tegra, Thermal Imaging and RTSP/Web Video support

Hi, latest version of Maverick - 1.1.5 is now released. this will be the last release in the 1.x series as big changes are underway for the next version of Maverick (2.0).

  • Support and OS download images for Nvidia Tegra platform. Tested on TX1 with dev board and Auvidea J120 carrier (thanks @SamuelDudley for donating the hardware!). TX2 image should work but not tested (any guinea-pigs would be great).

  • Support for Up boards (Up Board, Up squared and Up Core - These are brilliant boards for UAV use.

  • Support added for Flir One (v2) and Seek thermal imaging cameras. These fit perfectly into a Pi Zero for small, cheap, portable thermal imaging.

  • RTSP/Web Video. Maverick visiond has now been adapted to work as an RTSP server, so instead of having to specify a target IP address as is normal with gstreamer, any RTSP client such as VLC, Mission Planner, QGroundControl etc can connect directly to Maverick (and multiple clients can connect simultaneously, depending on bandwidth and resources). In addition, a simple web page with a (Chrome only) plugin that allows UDP RTSP based video direct to the browser.
    (Screenshot of Maverick streaming Flir One thermal imaging video from a Pi Zero to a browser)

  • ZeroTier networking support added. Zerotier is a really interesting ‘meta network’ model that is very useful to connect to craft over networking such as 3G/4G that does not have a public address to connect to.

  • MAVCesium now runs standalone (MAVProxy no longer needed), and can be connected to either SITL or Flight Controller.

  • Lots of improvements to the analysis/graphing system.

  • Lots and lots of small fixes and improvements generally.

Exciting changes ahead for the next version of Maverick!


TX1 install seems to work OK, I’ll get back to you on that one. I tried to install on my TX2 and ended up with no GUI. I then went back to JetPack and tried to reinstall, it flashed the OS but the LAN port no long is functioning so the remainder of the Tegra install is not possible. I now have Ubuntu GUI but no LAN, WiFi is functioning so I updated Ubuntu hoping to restore LAN port but no love. I think I’ll try Nvidia tech support tomorrow and see if they can help.

Hey, thanks for trying! Weird about the LAN port - does it work with the Maverick flash on the TX2, albeit with no gui? Did you try activating the gui after install? Might be that it was disabled for some reason in the image.

I tried every method I could dig up on the internet to enable the Wan port to no success, and I tried to reinstall Maverick again no love. The TX2 is in the drawer and I am patiently waiting for Maverick to configure itself on the TX1. How long should this take on a Tegra? Its been slowly cranking out lines for almost two days now.
Cheers RB

@rbachtell Hey, sorry for delay I’ve been consigned to sick bed for a couple of days. How did you get on with the TX1? If you follow the flash instructions in the docs, it should only take a few minutes and when it boots into Maverick it should be ready to go. A maverick configure should takes < 30 seconds after that. You’re not trying to bootstrap from a vanilla jetpack are you?
Feel free to head over to for some realtime help :slight_smile:

I think I know just about enough of this to get myself into trouble. I finally got my TX2 resurrected from the dead but can’t make any progress on the TX1 Maverick. It looks to me that I don’t have a proper image flashed. I have a GUI on the Tegra but I can’t ssh in or connect to the web interface. The GUI has a Maverick user and I can log in. I opened a terminal and ran the self update command and it looks like it worked OK. I re-flashed the Maverick image very carefully following the instructions with the same results.

That’s a good start! Sounds like you’re running just fine, but you’re not connected to the network. If it’s an ethernet connection it should work out of the box if you’re running a normal dhcp router. If it’s wifi, try running wifi-setup. If you’re running linux or mac on your desktop then you should be able to ssh or web into ‘maverick-tegra.local’, otherwise find the ip on your tx1 with ip a

OK, I finally made some progress. I did a maverick netinfo command and got in to the interface using the IP address on eth0. Can’t get in with the URL or ssh. Does Maverick establish a WiFi AP like ApSync?

Maverick doesn’t provide AP interface by default, but can do easily:
Might change this to default in a future version.

Hi, I need to stream RTSP over LAN from SEEK Compact PRO. I have Orange pi zero 2
will it run on it?