Mateksys H743-SLIM No telemetry


I’m facing a problem to get telemetry from the Mateksys H743-SLIM board.
My receiver is Frsky R9 mini.
I’m using Ardupimot 4.17.

At the beginning I’ve tried to connect it as F.port with the following setups:

FPort requires connection to Tx6 and SERIAL7_OPTIONS = 7 (R9 Mini set to F.port)
and then SERIAL7_OPTIONS = 135 (adding Tx Pullup).


All of the above with another Frsky Rx: Archer R6.

Then tried to use SBUS and S.port (R9 Mini set to S.port):
SBUS connected to Rx6 & S.port connected to Tx6 (after to Tx7 as well):

At some configuration, Frsky SPORT = 4 I get reading of the sensors at the boot but then they are not functioning except from the Heading.

Don’t know what I’m doing wrong.

Please your help.
Thank you

By using SERIAL7_OPTIONS=15 you are swapping the Tx and Rx pins, so you’d connect to Rx6 rather than Tx6. I did this on my H743 Wing v2 to allow the use of a standard 3-pin servo connector.

The Matek docs for the H743-slim ( say to use the following for F.port on Tx6:

If telemetry doesn’t work they suggest SERIAL7_OPTIONS=135 to enable Tx pullup. If you want to swap Tx/Rx this would be SERIAL7_OPTIONS=143.

Hello Chris,

Thanks for your replay.
Sorry, my mistake, I’ve connected to Rx6.
Anyway, meanwhile I’ve try to connect it to Tx6 without the swap option but still no telemetry.

Hi all,

I still can’t get telemetry, any ideas?
Thank you