Matek H743-Slim LED NeoPixel Not working [Solved]

Hello @rmackay9
I have connected “Panda RC WS2812 LED” to MatekH743-Slim,there are 4 LED strip each having 4LED and all of them connected in series, so you can consider it as Single 16 LED strip.
It was working perfect with iNav but now i switched from iNav to Ardupilot and LED stopped working.

I have installed " LED_roll.lua and other lua script but only 2 leds work.

have you followed the setup for them

Yes, i followed

the led pin is connected to servo output 13 according to Flight Controller H743-SLIM – Matek Systems


Correct, These are settings I made
SERVO13_FUNCTION=120 // NeoPixel1
NTF_LED_TYPES= 256 // NeoPixel

have you tried just setting it as a notification led without the lua to get it working first ?

No, let me try with those options and update here,thanks

Unfortunately Nothing worked for me

Sorry, I found one of my LED was broken thats why other serially connected LEDs did not work, now every LED work but not Flashing, how to make them Flashing when flying.

Thats what the scripts are for.

is it changing colours as a status led? if it is then electrically its working, you now need the lua scripts to get it to flash etc.

Yes, color are changing as per status, but i want it should flash when leave ground and fly

you will have to use lua to do that. i dont think there is a led setup program anywhere like they have on betaflight/cleanflight.

You are right, i tried lua script but none of script flash LEDs, any option.

This was solution for only one LED being worked.