MATEK H743 mini RC in issue

I flew a 3inch quadcopter with omnibus f4 FC and Hobbywing 4 in 1 esc without telemetry so far with Arducopter Firmware 4.0.7. Everything was running, but with this old FC I can’t upgrade to the latest Arducopter Firmware. Therefore I switched to the Matek H743 Mini FC and connected my Orange R110x DSM2 satellite receiver to rx6 on the FC. As your documentation for Ardupilot Firmware says nothing in detail about the configuration regarding serial7 when using a dsm2 satellite receiver, I changed nothing. So BRD_ALT_CONFIG is 0, SERIAL7 is -1. Only twice I was able to get the green bars on Mission Planners RC Calibration tab and successfully calibrated all channels. After reboot I don’t get the green bars anymore and can not arm the quadcopter. Everything else is o.k. I get the data from my distance and flow sensor, I am able to perform the motor-test within Mission Planner, but I do not get the connection to my transmitter (the sat receiver is bound to my tramsmitter). If I flash the latest Betaflight Firmware on the Matek H743 mini, the copter flies without any issues. Please tell me what is missing and if the v1.5 version of the Matek H743 mini really runs with Ardupilot firmware.
Thank you for your support,
P.S.: Statements:

  1. I am able to flash the FC in DFU mode
  2. I am able to connect to Mission Planner via USB
  3. I get all my sensor data wich are connected to the FC in Mission Planner
  4. If I see the green bars in Mission Planners RC calibration tab I am able to see the different flight modes on Mission Planner HUD when setting the switches on my transmiiter and can arm the copter
  5. the connection to my transmitter I only have random
  6. If I flash with Betaflight firmware on the same hardware, the quadcopter flies great.

Should work, maybe try BRD_ALT_CONFIG 1 and SERIAL7_PROTOCOL 23

1 Like

I tried this already but the result is the same, only very random RC input. So, what is the trick?

From the Matek website:

SBUS/DSM/SRXL connects to the Rx6 pin, but SBUS requires that the SERIAL7_OPTIONS be set to “3”.

My R110x is connected to Rx6 pin but what do I need for SERIAL7_OPTIONS for DSM2? So far I have tried 0, also 4 RX_PullDown and 5 RX_PullUp (this was a hint from MATEK support) with no success. SERIAL7_PROTOCOL I have set to 23 and BRD_ALT_CONFIG is 1. Is anyone running this board with a Spektrum or Orange satellite receiver and Ardupilot firmware?

Have you confirmed the sat rx is a working unit? Is there an led lit confirming bound?

Yes of course, the satellite is bound and the red led is on. As I wrote before this setup is flying with Betaflight firmware but not with Arducopter 4.3.2 so far.

I did a whole rewrite of the DSM stack based on some timing issues that never got merged - this could be what you are seeing. I’ll see if I can dig out the PR. One thing to try would be to set RC_PROTOCOL to only be for DSM

Thank’s Andy, I’ll test it and give feedback!

Looks like my change actually was merged. I’ll dig out an old orange and see if I can reproduce this.

I set RC_PROTOCOL to 32 (DSM) and the behavior is still the same.
Just for validation I right now flashed the Matek H743 with the latest Betaflight firmware and I can arm and fly the copter. So from hardware everything is fine.

Hi, Andy, if you need an orange sat receiver, I can send you one (R110x).

ok I connected a lemonrx sat (I don’t actually have an orange) and bound with DSM2 22ms. Connected to RX6 and reset all the parameters - everything worked fine. No configuration required, binding correct.

Try binding with a different frame rate maybe?

I can’t set different frame rate for I am working with a SPEKTRUM DSM2 Module inside a Graupner MC22 Transmitter. so this is fix with 1024 resolution and 22ms. Binding is always done with these parameters. Are there any parameters to set inside Mission Planner’s config list? Do I understand right, you have not set any parameters in the config and you have got connection to your transmitter and have been able to do the calibration? What is wrong with my system then for it is working with betaflight without configuration? What kind of FC-board have you used for your test?

I used Matek H743 Mini like yours. RX6. lemonrx satellite and Spektrum DX8. What frame rate and resolution are you using? These issues in the past were always timing related, DSM is very hard to decode properly - there is no good CRC - and so we do a lot of guessing. If the timing is off then problems can occur.

Frame rate and resolution should be 22ms and 1024 bit, that is what I choose in beta flight as RC-protocol and this is working. Have you set serial7_protocol to 23 or left it at -1 for your test? What was your parameter for brd_alt_config then?

I have not made any config changes. I set FORMAT_VERSION to 0 to remove all parameter settings

This morning I flashed Ardupilot again on my FC, started with default config and had no connection to RC. So it was with BRD_ALT_CONFIG = 1 and SERIAL7_PROTOCOL = 23.
I have right now tested my setup with INAV5.1. Also with this software my system is flying (as with Betaflight). I do not understand why the RC connection is running with Betaflight and INAV and with Ardupilot there are such problems. Do you have any advice for me how to go on with Ardupilot?