Matek f405 STD : No GPS

After building dozens of multirotors with pixhawks and cubes, a few with the Omnibus F4 Pro, I am building my first one with the matek f405 std.

I can’t seem to get this M8N GPS/QMC5883L Compass to function with this flight controller. I have it wired to USART 1 on the FC, and my SERIAL3 params are TYPE=5 and BAUD=38. The result of this is that the testing screen shows no gps present, GPS Status is 0, and HDOP is 655.35. The LEDs on the GPS are indicating it’s receiving data, and the mag works fine as well.

Here’s a list of things I’ve tried:

  • Swapped my working SiK radio from USART 3/Serial1 to USART1/Serial3 and put the GPS where the SiK was. I changed the params and the SiK radio works, but the GPS still does not. This proves that the port is correct.

  • Swapped out an identical GPS module with the same wiring. This helps but does not prove the GPS is not bad.

  • Swapped TX and RX lines. I know I had it wired correctly, but sometimes you never know with budget devices.

  • Changed GPS_TYPE to Auto, uBlox, and NMEA, rebooting in between changes. Made no difference.

  • Wired GPS to Omnibus F4 Pro: When I did this, it worked instantly with 38 baud, auto GPS settings. This proves that the GPS is not bad, and is at least ArduPilot compatible.

Is there anything I might’ve missed? Any help would be much appreciated!

How do you feed power?
You might need an external power source

1 Like

I feed power directly from the Matek FCHUB-6S, which has a 1.5a 5v regulator. The GPS module and a CCD camera are the only things on that regulator. The LEDs on the unit indicate the receiver getting a GPS signal, and the integrated compass does show correctly in Mission Planner.

I suggest you try another serial port, maybe it is defective

The same port works if I reconfigure it for a SiK radio, so I don’t think it’s the port. I’ll try the rest of the ports tonight.

Update: Without changing any wiring, I can flash iNav back onto the flight controller and all peripherals work. Seems like it might be an issue with the ArduCopter target.

Just tested this morning and I have GPS & Compass (With this cheapo NEO-M8N ):

According to

  • SERIAL3 = GPS1 = USART1 (TX1-RX1)

hello mike_d

I have the same problem as identical to yours. I check all parameters related with gps settings and I check hardware connections but no success.

gps connected to rx1 and tx1 on matek f405 std (tx-rx rx-tx), SERIAL3_PROTOCOL:5, SERIAL3_BAUD:38
GPS_TYPE:1 powered with 4s lipo

however compas is working properly.

gps-compas module was working properly on my pixracer so i know is not faulty.

this is my gps module

this is my parameters file

is there anybody flying with matek f405 (multicopter ) with properly working gps flight modes ?

thanks in advance

sakir polay

@ppoirier I have it working now! Thanks for all your help! I am thinking it was possibly bootloader related.

My first flash was to Copter using a hex I compiled from 3.6.5 release. I then re-flashed firmware only multiple times to plane and copter when trying different versions when trying to isolate the issue.

I had to overwrite the AP bootloader when I put iNav on to test that. When i flashed a new bootloader/image using the Feb 25 nightly, GPS worked! I even reverted to the 3.6.6 image (not overwriting the bootloader).

1 Like

hello everyboy

arducopter matek f405 std no-gps problem is resolved

here is how


Only serial3 protocol must be choosen for gps if you have only one gnss module on rx1 and tx1 on matek f405 std.

best regards

sakir polay

Where should I edit acorrding to your help?

These are parameters that you must change in the Config tab > Params

Hello everyone. I’m new to this forum and was wondering if anyone can help. I’m connecting gps to my matek 405 std. Parts arrive tomorrow. I have the top off the quad. And looking at the top of the matek, along one side are uarts, from right to left, RX1, TX1, G, 5V,3V3,G,VCC,CURR, AND RSSI. Am I correct in thinking that I wire the gps module to the tx1 and rx1. And the 5v and obviously G many thanks.

hello Ian

yes you are thinking correct. Arducopter wiki describes gps connection to matek f405 std as like this

may be you should make some alternations to serial ports. it is described above

good luck

sakir polay