Matek F405 CTR Frsky Telemetry with R9 slim+

I found a thread with someone using the RX1 (non-inverted) port with an f405 wing using serial_option 4, and matek’s website shows settings for the CTR using serial_option 7. I have the latest non-access firmware on my r9m and r9 slim+. I cannot get any telemetry working using either serial option(4 or 7) on the RX1 pin, or the normal S.Port pin. I was doing a full reboot between each option change, pulling USB and battery. I thought it might just be out of date firmware but someone replied in June 19 saying it worked and there was no Access firmware then for this receiver. Every once in a while when I did discover new sensor I would get a GPS field to pop up, but if I deleted and tried again it usually wouldn’t come back. I also tried frsky s.port instead of passthrough and still nothing.

Any ideas?

I’m using the TX4 pad which should be Serial2 in arduplane.

Reference thread here: S.port telemetry with Matek 405-wing

1 Like

One somewhat related question. Where is it defined that Serial2 is UART4? I checked the hwdef.dat file but it just lists the pins, I don’t see any references to serial 1, 2, etc…

Edit: I found what I think might transfer, but it seems wrong.

From the hwdef.dat file:

order of UARTs (and USB)


From mateks site:
Default UART order

SERIAL0 = console = USB
SERIAL1 = Telemetry1 = USART3
SERIAL2 = Telemetry2 = UART4

Is there a mismatch?


For the F405 wing UARTX=SerialX :

  • What lua script are you using, it worked for me with yapuu ?
  • Had you try to arm (without propeller for safety) ?
  • Had you tried the config i posted on June 2019 ?
  • What arduplane version had you flashed ?

Utimately i got a 765 wing… No more inversion shenanigans :smile:

I have yaapu, but im just trying to discover sensors before even activating the script. I have not armed yet, is telemetry only sent after arming?

I have the latest stable arduplane firmware. I tried the serial options you had and the ones matek suggests.

So you are using a 4.X version ?

Try the passthrought via Yappu. The ardupilot sensors will not show up in the discovery panel of the Transmiter.

And try :
connecting RX1 pin of the R9 slim + on the TX4 pin of the FC

Ah, that is probably my whole problem then. I have used telemetry with iNav and another script and you had to discover the sensors first to make them show up, I just assumed that was the same for this. I will try just using yaapu tonight and report back.

Interestingly I got this partially working, but using 7 for serial_options instead of 4. I had my taranis settings messed up where the lua option in settings wasn’t enabled, I had to reflash the firmware to enable it and now my telemetry works.

edit: spoke too soon… I get the initial messages on my taranis and then it stops updating… It seems to only work on power up, if I turn off taranis and turn it back on no updates. If I turn off the flight controller and reboot I get the mode and battery stats, but then it never updates. I am definitely getting real data, it’s reporting the arduplane version and some IMU config status and then it just stops. It behaves the same with serial_options at 4 and 7.

I found someone else with a similar issue on an F7 board. It turns out that Serial2 port behaves this way in ardupilot currently(stops sending telemetry after some time). I soldered to the TX3(serial 1) pad on my FC and everything works now.

Posted an issue to github

1 Like