Matek f405 - check brd_type baro error?

FC: Matek F405-STD
Baro: BMP280 (according to Matek site)
OS: Linux (Ubuntu)
GCS: QGroundControl

Tried both stable and beta firmwares (flashed thru iNav) and when I connect in QGroundControl I immediately get “Check BRD_TYPE: baro - Unable to initialise driver”

I just built this quad using iNav and verified everything was working there. I could successfully do pos hold, rth, etc. I’m more familiar with BF but was hoping to use Ardupilot as it’s waypoint system is much more mature.

That generally happens when you try to run with just the USB power. Use a 5 volts supply just to make sure

I get the same error regardless if I have a battery plugged in or not.

What is weird is that I can go under Settings > Sensors and calibrate the pressure and it says the barometer is calibrated?

Just chiming in to confirm I get this error too, on Matek F405 CTR. Appears in Mission Planner and APM planner. Battery plugged in or not. 3.6.6/3.6.7RC/3.7.0dev.

I had the same issue for days. This is what fixed it: plug in battery. After beeps, plug in USB.

I went crazy and kept getting same results. I tried older versions of Matek F405 & STD variants and even rover and plane variants. One thing I noticed from running iNav is that the barometer will not work unless the copter is off and battery is plugged in first. Then you can plug in USB and it will still work. Try this - plug in batter and then USB and tell me if you keep getting barometer error.


same thing happen with me on FF35 lightning board, need to reboot / repower couple time and then working normal. but mostly is not working.
please help

Did you try plugging in the battery to the FC, waiting a few seconds, then plugging in the USB?

yes i do as per your guidance but still persistence.

Thank you rolyexpress!!! Worked!!!

1 Like

Based on this post, there may be I2C interference:

However, I had a different error than the OP: Check BRD_TYPE: Baro: unable to calibrate

Originally, my SDA/SDC wires were routed against the flight controller past the SD card slot. After routing them away from the flight controller, I stopped getting the errors.

1 Like

I have the same problem and to solve I have to connect the lipo battery first. Was it enough for you to pull the cables apart? Do you have pictures? Thanks!!

Same here with Racerstar Nano wing, f405wing target

I have same issue with F405-STD and keep getting no matter how i orient cables

I have same issue with F405-CTR and keep getting no matter how i orient cables

I had same problem, this issue is because barometer is powered by bec,i then powered by usb and it worked.
Check your fc document for power layout