Massive amounts of noise on US-D1 radar rangefinder, leads to erratic altitude hold

I’m using a US-D1 as my rangefinder, and there is massive amounts of what i think is noise in the system. When switched to break mode, the vehicle holds altitude fine. when vehicle is above rngfnd_max_cm, it holds altitude fine. While using the rangefinder, the vehicle bobs up and down erratically in a range of about a meter. I’m flying over a grass field and the radar clears all landing gear within its FOV of 43 deg.

I tried changing the rngfnd_filt parameter from 0.5 to 5hz, it changes nothing. Is this parameter not supposed to smooth out the rangefinder signal? CTUN.Salt follows rangefinder exactly.
The top is 5hz signal, bottom is .5hz. separate flights as i rebooted in between, but They’re both synced to 20s.

I’d love any help, especially with why rngfnd_filt is not smoothing the rangefinder signal (if thats what the parameter is supposed to do). Thank you.

The surface tracking by rangefinder has some logics to prevent glitch on it, and this is not the worst signal I have ever saw, are you sure your altitude controller is doing well? Tried to disable surface tracking to check how it behaves only on barometer?

It is always a good thing to post the logs so someone can review and try to help.

yeah ill try to get logs out soon. the altitude hold with just the barometer does well. it’s extremely evident seeing the vehicle start and stop oscillating when surface tracking is on/off. really points it to being a rangefinder issue, esp since I’ve used this rangefinder before on CAN and its precision is very good, it definitely doesn’t jump up/down 30cm.

Here’s the log file for the .5hz filter:

heres the log for the 5hz filter:

Man, I took a quick look here, and your rangefinder signal seems very ok to me…

But I have other consideration about your logs: update your GPSs to the latest firmware ASAP! You are having some messages flooding indicating that you are running out dated versions.

I really do not know if there is anyway to improve your performance, maybe putting EKF3 sources of height on GPS instead of barometer could help you, despite the fact I found your baro signal ok…

And if possible, update to the latest stable ArduCopter 4.3 version.

What sensor is this one exactly? You had to use start using it because of the GPSs here you installed on the CAN bus?