Servers by jDrones

Marvelmind integreation: BCN parameter not found


(BeeEm) #1

Hey folks,

I’m having some trouble connecting the Marvelmind Indoor-GPS to a Pixhawk1 running Copter 3.6.0 (stable). Following this instruction http://ardupilot.org/copter/docs/common-marvelmind.html I’m not able to find any of the mentioned “BCN_” parameter.
Am I missing something? Is this the right instruction to follow, to get indoor navigation working?

Thanks in advance.


(rmackay9) #2

@BeeEm,

I suspect the issue is that -v2 has been loaded onto the vehicle instead of -v3. You might want to try downloading and then specifically uploading -v3 using the ground station’s “Custom firmware” option. the 3.6.0 for -v3 is here for NuttX (look for ArduCopter-v3.px4) and here for ChibiOS (look for arducopter.apj).

By the way, the difference between -v2 and -v3 is that the -v2 firmware must be smaller (i.e. less features) so that it can fit into Pixhawks which suffer from the “1MB flash limit”. This “1MB flash limit” issue is a hardware issue in the CPUs created by ST micros - the hardware issue was resolved in new CPUs from ST Micros but Pixhawks made with the older CPUs will suffer from the problem.


(BeeEm) #3

Thank you very much for your help. I managed to install the new firmware and found all necessary parameter. After completing the installation, I run into another problem. The drone sometimes jumps to the correct location, only to disappear from the map shortly afterward, printing the message: “EKF3 IMU1 stopped aiding”
Has anyone noticed something like this before?