Servers by jDrones

Maiden Flight - Hexa unstable hover

Hi there! Thanks in advance for your time in my help request.

I just finished my DIY hexa. It’s my first experience in Ardupilot. The maiden/tuning flight was some like frustrating 'cause the copter was very unstable hovering. I even couldn’t check yaw/pitch/roll tuning.
I fought all the time with throttle in stabilize mode. It was impossible to keep the vehicle in a certain altitude. The copter required so little throttle to start climbing (two stages on stick), but didn’t stopped. So I needed to decrease (one stage on stick) throttle and it started to lift down.

I tried basic tunig, with no success. After that I needed to give more throttle for start to climbs. But again, with no stable hovering (it doesn’t stop to climb). When decreased throttle, it start to lift down quickly.
I broken one leg from landing gear in one of the ground impacts of copter. I’m afraid of doing advanced tuning and get more damage on this unstable copter. Any ideas?

The hexa:

  • FC RPi4 + Navio2 board
  • ArduCopter 3.6.11
  • Tarot FY690S Frame
  • Sunnysky X4108S 690kv
  • 13"x 5.5" Carbon Fiber Props
  • Battery 4S
  • AUW about 2500g (no payload this moment)
  • RC TX Futaba T10J + RX R3008SB
  • Telemetry 4G/LTE

All calibrations done successfully.

Some logs from today:
log_18_2020-8-15-12-00-44.bin (139.4 KB) log_19_2020-8-15-12-06-09.bin (183.3 KB) log_20_2020-8-15-15-21-18.bin (111.7 KB) log_21_2020-8-15-15-37-16.bin (603.3 KB)

You can change the ratchet spring of the throttle by the flat one (used with copters). It should be somewhere in the TX box. If it is missing (copter version only?), place the spring up side down to decrease the ratchet effect.

ratchet spring

Your Tarot is overpowered. I use a lead box (same weight as payload) when tuning my multirotor.

For tuning, go to

https://ardupilot.org/copter/docs/tuning-process-instructions.html

Set default parameters for your prop size and do a manual tuning.

1 Like

As @mlebret stated, the aircraft is slightly overpowered which might be why you are having trouble maintaining altitude control. This can be seen in the logs, but also after looking up your motor/prop/battery combo. Each system probably produces around 2kg of thrust at max throttle - thus giving the hex 12kg of thrust. 12/2.5 equals a 4.8:1 T:W ratio - which is very high. Most copters range around 2-3 T:W during normal flight. This is not too much a problem, just will require some extra tuning and will probably be easier to fly in alt-hold/loiter mode.

There are two ways you can go about “fixing” this.

  1. Add a payload - I would suggest about 1000g to start off with.
  2. Decrease to 3S battery - in the event that you have one laying around.

Once you get stable altitude control, try alt-hold and loiter mode in flight to see if everything is working well. Lastly, you should be able to revert to the current setup and test alt-hold/loiter mode. These modes will control altitude for you - so no more fidgeting with the throttle.

3 Likes

Agree. Add a bigger battery! I choose the battery last on a build and base the selection on the thrust:weight ratio :slight_smile:

2 Likes

Thank you all for help!
I’ll try the suggestions and go back with results!

1 Like

Hi there!

After some time, I could test the tips above.
I added about 1000g of lead to the frame and it was easier to control throttle.

I almost could do the autotune, but I got a lot of warnings in GCS about mag field check!

Trying to find the source of mag interference, I started an elimination strategy, turning off thing I could do: BEC, retractil landing gear, lte modem.
I found out the source, which was the LTE modem. Actually I think it’s wasnt the modem, but the USB extension I put to unplug modem from FC, avoiding vibration on board (navio2 + RPi 4).

So, whithout telemetry I did more 2 short flights but couldnt do the autotune.

Now I’m looking for a good/shielded usb extension to plug lte modem and I give you guys new feedbacks.

Some pics:

The Copter:

Leads added:

Top view:

USB extension unplugged:

Thanks in advance.

Hello @mlebret @manavgandhi17 @dkemxr,

After a while (bad weather) I could resume the tests. I still in trouble with throtle. As I sad in last post, it was a little bit easier, but not really a stable hover. I put weight, adding about 1000g of lead in frame. Should I add more?

I couldnt do a slightly take off or landing yet. I broke 3 more landing gears sets :weary:

Hovering is only one of my troubles. I facing a lot of bad readings of GPS and compass/mag field. A little attempt to flight some GPS modes almost send my copter away… I could get back to stabilize and brought back to land, hardly!

Dataflash log: log_8_2020-9-19-08-35-57.bin (399 KB)

In fact, I giving up of Navio2 as FC. I just bought a CUAV Nora FC and will replace as soon it arrive. I think with Nora I will eliminate bad readings of sensors, but the hard hovering I think I will remain facing.
More weight is that solution? Is there some specific tuning that I could do?

I bought 2 new lipo 4s 10400mAh bateries (waiting to be delivered).

Hello all,

Today I tried new copter modifications (while the new FC CUAV Nora does not arrive).
I changed the props (before CF 13" 5.5) to nylon 11"4.7".
I also made some Emlid guys recommendation, like: moved the Futaba Rx and antenna to under the copter, looking for decrease RF over Navio2 board (I keep struggling on compass/mag field interference) and removed LTE modem. Installed the GPS antenna over a metal plate, trying to avoid multipathing effect.



In Stabilize mode, even with no tune yet, I’ve had good controls over Pitch, Roll and Yaw. But I still fighting with the copter on throttle. It`s hard to keeps it hovering. One single throttle stick ratchet level up, the bird starts to climb up… One step back in stick, the bird starts to goes down. It was not so agressive as with 13"props, but still hard, specially to land smothly.
When the FC is doing the job, in AltHold mode, it was easier to hover, with a certain good control.

MOT_THST_HOVER (LearningAndSave) increase from 0.22 to 0.28.

The GPS glitch still happening, less frequently, but it still there. I had also mag field check pre-arm error. Also less frequently, but happened too.

Today`s log: https://www.dropbox.com/s/s0ui9x8dwaiuoc9/log_0_2020-9-27-08-17-07.bin?dl=0

There is no expectation of a stable hover in Stabilize mode. It’s completely throttle controlled.

You have to replace the ratchet spring by a flat one and smooth the ratchet.(youtube)

Landing and take off stability: Enlarge the base. Your LG skids are too short.

GPS glitches: Maybe some progress with arducopter 4.0.4. I have to fly and check but ground test are fine. You can also use some hot glue or silicon on the GPS plug.

Ok, I’ll try to find here down in Brazil the flat one spring. It didnt come in the futaba box.

Here it’s easy to see the “up and down” of the throttle stick, trying to keep the alt.


It’s such a sensitive thing. Do you think I could control manually this little range removing the ratchet spring from throttle spring and get a better hover?

It’s true. I replaced the 10mm skid (weak for ~4kg) by 16mm tube. I had only one 50cm long tube, so each skid is 25cm long. I’ll put at least 35cm each side.

Emlid released a new Navio2 image with 4.0.3 ardupilot firmware. I burnt the new imagem and updated to 4.0.4. Waiting a good weather for new tests.

Thanks in advance.

Servers by jDrones