Servers by jDrones

Lua script on a 3DR Pixhawk Mini No Scripts To Run Issue

I Created the “scripts” folder in the APM folder and added Lua scripts one at a time (hello world etc) and tried multiple in the folder. I also enabled scripting. I always get the “no scripts to run” message.

Another piece of information just in case it matters, I had flashed my Taranis QX7S with a new firmware version and it no longer turns on. So I do not have any transmitter receiver link at the moment. I am just running the Pixhawk Mini with the USB cable.

My immense complements to the ardupilot groups…as a retired software engineer, this is cool stuff. I am very new to ardupilot and drones but very interested. I am working on a drone project with one of my sons. Thank you!

image

Hi Frank,

AFAIK, Lua only runs in boards with 2Mb of flash size.

If you want to test your code, maybe you could check out the SITL environment. You can run a simulated vehicle and command it without any hardware:
https://ardupilot.org/dev/docs/sitl-simulator-software-in-the-loop.html

I am not sure how to use Lua Scripts there, but I guess it is possible and more complete than a board without a receiver or radio. You can also connect the mission planner in the simulated vehicle.

I believe that FC does have 2mb flash.

Pixhawk mini

Looks like you may be having memory issues, Terrain has run out of memory.

It will tell you what the issue is before it gives the no scripts to run message, you have to connect very quickly to catch it on boot.

Thank you all for your responses! Problem solved!

I connected faster and saw that the hello world did run.
The messages I had seen said “no Lua scripts to run”. I interpreted that as that it could not find any at all to run.
I put in the looped hello world and it runs perfectly. A better message may be “No Lua scripts left to run” or something like that. For us very new Lua people!

thanks again!

2 Likes
Servers by jDrones