Low link quality of UAV and GCS when using ZeroTier

Hi I am using Zerotier to communicate between UAV and GCS via internet. I have collected link stats from the ground station. I noticed that Pkts Lost keeps increasing. I think, my link is not P2P, but I don’t know how to verify the link between UAV and GCS is P2P or not. Please give me advice to improve the quality of the link. Thanks for your help.

You may have better luck on the Zerotier forums.

In the past I’ve found that 3G/4G communications links can be a little unreliable. Try using a wifi/ethernet internet connection at both the UAV and GCS ends, and see if the reliability is better.

1 Like

I tried using ethernet on both terminals. The quality is slightly improved. Thank you for the suggestion.

Make sure your trafic doesn’t go trough moon instead of direct p2p.

1 Like

Hi, zerotier i did not configure moon. After checking with the command “zerotier-cli peers” I noticed link = DIRECT. It is a direct connection between two devices. Although it is a p2p connection, the link quality is not guaranteed. Do you have another idea? Thank you for comment.

We use an OpenVPN server for our commercial services. Zerotier is a bit of a hit and miss.

Hi, when using OpenVPN, the traffic will be transmitted through the server. So how about control delay and link quality?

We have an average delay of 150 ms from ground station to uav and vice versa.

1 Like

Hi, how can we monitor that delay during control?

Hi Stephen, I am wondering a problem, hope you can suggest me. I linked the UAV and GCS through Zerotier.
+, When I use UDP connection, I have the following settings and the UAV connects normally to GCS:
RPI setup: TELEM1="-A udp:"
On wireshark software shows port RPI: 58531, GCS: 14550.
+, When I use TCP connection:
TELEM1="-A tcp:"
In the Mission Planner software I entered the IP address of the RPI and the port : 58531. But this setting failed to make the connection. Thank you for your help.

Is there a particular reason you need to use TCP? Most people use UDP for telemetry.

1 Like

Hi, I have never used TCP connection, when using UDP connection, I feel it is unreliable. Even when streaming video. That’s why I want to try using a TCP connection, to compare the quality between the two ways.

Hi, I am wondering, the port value in RPI’s setting is the destination port (GCS’s port) and GCS is the source port (RPI’s port). Is this right? Thank you.

What software are you using on the RPi? I’m not familiar with the TELEM1="-A tcp:"

Hi I solved the problem, I used port 5760 for TCP connection.