Loss of Yaw control which led to controlled crash with hexa - Copter 3.4.3

Hi guys. This is my first post. I had a strange experience a few days ago. I recently installed copter 3.4.3 and had a few great flights. It felt nice and smooth and stable. But a few days ago I lost Yaw control and had a hard landing. About my setup:

Arris M680 Hexacopter
13 inch Props
Sony nex gimbal
Pixhawk 3.4.3
Gens Ace 6s 5000mah
433 Telemetry
5.8ghz video link
2.4 Radio Receiver

A few days ago I went for a flight. Everything went fine for the first 6 minutes. I came in to land, disconnected the battery, adjusted the gimbal and then took off again with the same battery (still had enough voltage to fly and enough for emergency…) I flew in stabilize. I hovered for about 30 seconds and all of a sudden it yawed about 90 degrees clockwise. I tried to correct but it did not want to respond properly. My Pitch and Roll worked fine but I could not Yaw. I assessed the situation and the best thing to do was choose the softest looking bush… Luckily no damage as I kept a low altitude.

Can anyone guide me as to what went wrong?

2017-01-09 06-26-11.bin (350.0 KB)
2017-01-09 06-26-11.log (727.1 KB)

I have attached the log of the 2nd part of the flight (When I lost Yaw control)
I noticed that the Euler Yaw look strange to me…

I didn’t have time to be super thorough, but this is what I see.
The vibes are crazy high. Clipping events are accelerations that can’t be measured.

These inovations are for the velocity estimate and the mag. Once they exceed 1, the EKF bailed to the other solution. There have been reports of Yaw jumps, about 50 degrees in your case, on the lane switch. Not sure if those reports were during 3.4.3 development.

I’d sort out the flight controller mount first.

I would add too that in the autoanalysis,this was seen:

           Compass:  FAIL       Large change in mag_field (175.02%)                        [GRAPH]
                                Max mag field length (564.19) > recommended (550.00)

Thanks for the replies guys. Those vibrations are high now that I look at it. Ive been struggling with vibrations for a while and I thought I had them under control. I have been focusing on the vibrations tab and not the vibrations 3.3… I’ll sort my mount out.

I will also do a compassmot test. I assumed that my electronics were far enough from my gps unit. My esc’s are directly under my motors. My Pixhawk controller is above my PDB… And my battery is above my Pixhawk. Don’t know if that is an issue.

Will report back.