Loiter (turns) fails to auto sequence

I need to create missions that will fly through a “survey” of Loiter (turns) waypoints. These missions look correct when built in ground control and are read back correctly from the copter. When I attempt to execute a mission using auto, it will not work. The copter approaches the Loiter (turns) waypoint and sits on the waypoint without spinning. I toggle out and back into auto and the copter performs the correct turn/spin, moves to the next Loiter (turns) waypoint, and once again waits for me to toggle. I have attached a mission that I have attempted to fly and had this problem. I have attempted building missions from QGC & MP with the exact same result from both ground control systems. Any ideas on what might be causing the problem?
UW 2_SAR.txt (4.8 KB)

Any chance you have a dataflash log? Also which version of the firmware are you using?

So…how do I see what version firmware I am using? As in, ArduCopter? Or is it 1.0, 2.35 kind of thing?
Here is my flash log with the corresponding mission that I flew. Log file was too large and the site wouldn’t let me upload it.
SAR.zip (3.0 MB)

Found it: ArduCopter 3.4.6

I noticed the WPNAV_RADIUS is set to zero so this is the reason it’s getting stuck at the waypoints. I’ve seen this enough times that I’ll add a check into the waypoint controller to ensure people don’t accidentally set this below 10cm.

Thank you rmackay. I intentionally set it to zero, but I will increase and hopefully it will work. I’m sure we can compensate for the radius of the spin, but is there any plan to eventually support a 0 cm spin?

So the CIRCLE_RADIUS can be zero and that will make it do a panorama shot (i.e. spin in place) but WPNAV_RADIUS of zero means that it never thinks it’s reached the target because it can never get 100% exactly on the target point.

I tested out the limits you suggested and found them to be slightly different. The mission would not auto sequence until I set the radius to 2 meters. When I tried 0.1 m (or anything below 1), the waypoints were created with a decimal but read back from the copter as 0 m. “1 m” was read back properly, but did not auto sequence. Then, 2 meters was the threshold. Thank you for the help.