Loiter Mode Problem


I am at a loss as to the issue with my quadcopter when I switch it into Loiter mode. Whenever I put the copter into Loiter mode it maintains height but drifts and doesn’t respond to any controller stick movement (throttle / yaw / roll / pitch) meaning I have to switch out of it quick. I haven’t tried any other GPS based modes which I assume are affected as well. Stabilize mode and alt hold mode work great as well as simple mode (thus I know the compass is working). My current setup is as follows:

FC - Pixhawk (latest V3.3.3 firmware)
GPS - 2 x M8N
Transmitter - Frsky Taranis with L9R receiver
Telemtry radio - 915 mhz

This issue has been present from the start with this copter even though I regular pickup more than 10 satellites on both GPSs . The troubleshooting I’ve done is as follows with no change in Loiter performance:

FC - upgraded the firmware / set the parameters to default
GPS - switched out the old GPS for a new one which I know works, added an additional one for redundancy, and elevated the position of each GPS to reduce MAG interference
Wiring - double checked the connections to the Pixhawk

Some pictures of my current setup attached. Help as I’m out of ideas!

Try a single GPS, and set the Logging bit mask to full (655358) and report back the corresponding logs.

Hey, ok so I disconnected the 2nd GPS and set the log_bitmask parameter to 655358. I flew the copter and tried loiter again with no success same issues. Just a slight correction from before in that I do have throttle and yaw control but no roll/pitch control.

The auto analysis of the flight log gave this result:

I have no idea why there would be a GPS fail as mission planner shows a lock of more than 10 satelites when I was flying. Not sure what an IMU mismatch would mean either.

I’m rather new to the logging aspect of Mission Planner and will need some direction. I downloaded the log and the bin file is like 100mb. I can pass it along if you know of a way to send such a large file? Otherwise if possible please let me know what I should be looking for and I can try to pass along screen shots. Thanks for your help.

About logs, what people do is do place them on s shared storage like dropbox, onedrive, googledrive, etc and place a link here. It’s only the BIN file.


Sorry for the late reply. The bin file can be downloaded from the following link:


Thanks for any help you can pass along! I have the feeling though the Pixhawk might be faulty.

Anybody any thoughts?

Sorry, can’t access the log file.

You can’t download it or you can’t load it in Mission Planner?

Can’t download it.

perhaps sharing permissions ?

ok try the link again please:


Link should work now as I tested it on another computer with none of my credentials.

Ok the problem is SOLVED. I switched out the Pixhawk for a Pix Lite (Pixhawk varient) which the loiter does work on, loaded the Pixhawk parameters, and guess what the Loiter still didn’t work. Clearly this told me that the issue was a parameter issue.

I reset all the parameters back to default in V3.3.3 and then manually updated the important parameters, recalibrated everything, etc… and voila the Loiter worked. I then saved and loaded these new parameters from the Pix Lite onto the Pixhawk, switched out the FCs, and now the Loiter works on the original Pixhawk. I can only surmise that updating the firmware before on the Pixhawk did something odd with the parameters which caused the issue.

Probably related to this.
Austin M