Loiter is slow to respond about pilot control

Hi all,
I’m posting here beceause I need some help or guidance to tune my loiter mode. So let me explain my config, I have a copter 6 motors F60 with F35A esc. I’ve mounted a Intel t265 with RPI and one forward Lidar. All this setup works I can swith between AltHold and Loiter I don’t have any errors, in Loiter mode my copter keep very well the position.
But for now I think I don’t have a good Loiter configuration beceause when I fly my copter is very slow to respond about pilot command.

For example when I switch in Loiter mode if I go full throttle forward and I release the stick to the center, the copter doesn’t stop rapidly he continues to moving forward for 2-3s after that he stops and goes back for 1-2s and after that he only stops to maintain the position, all this priocess take about 3-5s after I’ve released the stick, it’s depend about the veloccity.

I don’t have this problem in AltHold my copter is very responsive to my command. So my question is, should I tune my PID for Loiter, tune parameters ? I’ve already try to modify LOIT_ACC_MAX LOIT_BRK_DELAY but nothing change.

Bin file

Did you tune this vehicle? There are some overshoots on both the roll and pitch axis. It might be a good idea. Try LOIT_BRK_JERK too. It is the lowest value (500) in your vehicle. Increase it with 100 steps until you get a desired behavoir.

I tuned the vehicule for AltHold I’ve update PID to have a good copter, but for Loiter I’ve only tuned LOIT_BRK_JERK and LOIT_ACC_MAX and LOIT_ANG_MAX.
Yes when I looked log after a fly, I often have overshoot between desired roll/pich and real roll/pitch.
So I’ll follow your advice and try to play little with LOIT_BRK_JERK :smiley:

1 Like

you need to run Autotune to tune the vehicle PIDs, if its running all stock it will be very sluggish.

Update. So I’ve try to change LOIT_BRK_JERK but no changes for me, the drone is always slow after I realseaded the stick to the center. For me the only parameter should be help me is LOIT_BRK_ACCEL but this param value is 250 and this is the max value. My hexa take alaways about 3-5s to stop after I’ve released the stick to the center.

I’ve follow this tuning process and this is better I have no more vibration.

I’ve never used Autotune function, I’ll try it

It’s not the max value, increase it if you want. Ignore the 25-250 guideline in the parameter list.

Oh really? I thought if I went over the limit, my value will be rejected and the max value (250) will be use. So nice news I’ll try to increase this value and see if I have better response :slight_smile:

No, most of those ranges shown in Mission Planner are “suggested” and some are not up to date. Try 500 cm/s/s.

These are good, we use as defaults in our builds:
We set LOIT_SPEED based on battery current/efficiency and intended purpose.

If Loiter is not behaving as expected then it’s a sure sign of a poor tune, or no tuning, and it is struggling with attitude and position control.

Nice thanks @xfacta I’ll try your parameters today :smiley:

When you say that, do you have a link or math formula to determine this speed based on battery ?