Loiter acting up with Beta

I sent my logs to the DEVs and i now have time share my issue in it’s own category in case the Dev’s need to see my issue with the new firmware as one post as requested.

My first issue is loiter is shaky and has only got worse as the new builds have progress. After a few months I at a loss. I do not think it’s the tuning as i have a good grasp on the subject.

I will start with this image i made a few days ago. I happy to post images of my logs but request you ask for a image of what you like to see as I do not want to post my location from any spam.

One more from one of the DEVs.

My PID’s

Also as requested I was asked to tell the version of the firmware that works ok. version arducopter.apj Tue Feb 23 00:37:36 2021 808206

Noticed that there seems to be a difference in size of the two version stable and beta , That could be error checking,

Part of what i like to is to print custom frames then build and finally test like the location one last year.
here is video of my testing last year: this is the mRo v2.1 with the location one GPS basically stock tuning this is the bar of performance i used to using AP and MP.

this is what i have using Beta7 in loiter only stabilize flight is ok.

My plan for this frame is to convert it to a H-wing although it has nothing to do with the frame as to my post. for now i stuck in quad mode.

My second issue is the ground effect in copter is no more or not turned on, instead of gliding on the surface, beta seem to drive down like it has a mind of it own. flying on the surface is a great way to get the craft acclimated and happy and fun! especially if your on a cliff and have step downs and 30 degree grades. I like to see this effect return to copter.

Thanks all.

I would anonymize the logs and attach them.

Hi, how do i do this? Note pad.

Ctrl>F Menu in Mission Planner. Then the “Anon Log” button. A file open dialog box opens, you pick the file and save it as a .log file. Not everyone is happy with a .log file but it works in Mission Planner for analysis.

1 Like

Logs will be good to see but re the upward facing frame, from the sound of the motors it seems the roll and pitch rate gains are too high.

Try reducing ATC_RAT_RLL_P/I/D and ATC_RAT_PIT_P/I/D all down by 20%. Also I think if you’re not going to try and use AutoTune it is good to keep the ratio of P/I and D the same. So just raise or lower all of them by the same percentage.

1 Like

Hi Randy, Roger You have them I sent the logs to Discord today as a PM. Regarding the sound, the sound is with the new beta 7 in loiter and not in stabilize.

Tuning. Post some logs. This isn’t Discord it’s User Support which Discord is expressly not for.

Hi Dave, I work doing 3D with Tridge on Discord and he asked me to post some of the issue I have in that group. Can you ask me what you like to see? this way i can learn.

One small change I see between the 4.0.7 logs and the 4.1.0-beta7 logs is that MOT_PWM_TYPE has been changed from 7 (DShot1200) to 5 (DShot 300).

Another unusual configuration is that the AHRS_ORIENT = 24 (Pitch up).

@quadsours I was wondering if you could try switching back to EKF2 to see if it makes any difference?

  • EK2_ENABLE = 1
  • EK3_ENABLE = 0

… and then reboot the autopilot. This would help cut the problem in half because we could be more sure whether it is an estimation problem or a control problem (I suspect it is a control problem but both have changed greatly in Copter-4.1 vs 4.0).

Hi Randy, Regarding the Dhsot speed that was at the end of my test cycle i started with 300 then 600 then 1200. none of the speeds had an effect as to my issue. I will return it to 300… I also like to say shaky issue was also on the PRP,

Roger that- BTW what firmware should i flash or should i stick with Beta7.

Quick question will the Kakut F7 let me use this option? Normally I use the PRP but i had the USB come loose. " my fault "

Needed for my frame design. I can try AHRS_ORENTION 25 but seems to fly fine and looks right in my HUD.

KakuteF7_Feb 23 .apj (789.3 KB) Firmware