Logging failed - not able to arm

I just “finished” building a Mateksys F405 based drone with a 4-in-1 ESC.
But I am not able to arm. I get the error shown below.
When I reied to review the logs I got a “no logs to download” message.
I read in some threads that I should enable logging feature.
Please let me know how I can do it or what I should do.
I do have an SD card on the controller board.

The rest seems to be working fine.
Thanks a lot!

It’s enabled by default, no need to change any parameters. And if you did set them back to default. Start with a good quality Sd Card, format it FAT32 in a reader connected to your PC and install it.

Hello. Thanks for the advice.
I formatted an Scandisk Ultra 32GB SD card that I had around in FAT32 format, but I still got the “logging failed” message after a few seconds, and was not able to arm.
After that I removed the card and found the following new folder and files inside:

I will go buy a new card just to make sure this one is not corrupted.
The only information I have is this:

If you think it could be something else, please let me know.
Thank you!

Make sure the SD card and the slot are clean and the card is secure. I’ve taken to using a small bit of electrical tape on the Matek boards to hold the cards in place.

Hello, Allister. Thank you for the advice.
I installed a brand new SD card but I am still not able to arm.
Since there is vwerry little space I had to move the dron around in order to get the card in (I have the 4-in1- ESC board on top of the Flight Controller board and at first I got a compass discrepancy warning.
That went away, then I got a Radio fail Safe warning and then I got the Logging Failed message again.

I checked the card file folders and like last time I get some new folders with some backup files as shown below, but I am noticing there is no date.

So my impression in that the drone sees the card but for some reason it does not write the logs…
I know it looks messy, but here are some picture of the build and the stack …

Any suggestions will be greatly appreciated!

Hello again and sorry for so many iterations.
I decided to change the stack layout in order to be able to access the SD card more easily and now it is as shown in the picture the card seems to be well in position but I still get the error message.

I know you would not recommend it but is there any way to arm by disabling the logging feature?
First I would like to see if the drone flies as expected and then come back and work again on the details.

Thank you.

You’re going to need the logging. I don’t recommend how you have the ESC mounted because it’s going to vibrate and bounce and cause you a ton of issues just hanging on two screws like that. Especially on a 3D printed frame.

If you’re moving the drone around, especially inside where the compass is getting a lot of interference, then the compass errors are normal.

Take it out side where you can get a good GPS lock. Fully charged battery. Radio system turned on and connected.

Try different SD cards. Format them and try again.

Yes, I understand what you mean.
My intention is to fix everything so that there is no vibration.
I am doing a new full format on the SD cards, not the quick format version.
So I will try again and I will try different cards.
Thanks a lot!

Hello again. Thank you both for your help.
It finally worked and I was able to arm. Here is what I did.

First, in the MATEKSYS HP they mentioned having SD card compatibilty issues and I can´t recall exaclty where but I found a note where they suggested using SAMSUNG microSD EVO plus (Red)
I could not find this card but I learnt that this is a SDHC type of card which means “High Capacity”. So I got a 32 GB ScanDisk SDHC. (It is 4 times more expensive than a conventional cards, but these are recommended for faster app speeds and for drones)

Then I also realized my Ardupilot settings were wrong. I had the LOG_BACKEND_TYPE = 4, but MATEKSYS HP specifies to set LOG_BACKEND_TYPE = 1 (File) for SD card logging with ArduPilot.
So that´s it. It finally armed! Thank you againg for all your inputs!

1 Like