Servers by jDrones

Location One Calibration "BAD RADIUS" Issue [SOLVED]

Hello guys!
I’m facing “Bad Radius” error on mRo Location One GPS running RM3100. The model number is M10070(version without Baro). I tried various MP versions and Ardupilot builds but couldn’t get it to work.
I also updated to latest stable AP_Periph. But same result.
In one of the logs below, I have attached here2 with Location one for reference. Here2 calibrates with auto orientation but RM3100 doesn’t.
Thank you!

https://drive.google.com/file/d/1z4PHPIOz7tiUrtd9oUBlI2RodrmxK5M8/view?usp=sharing
https://drive.google.com/file/d/1jocl96L2JppXhW78wWcA4RYQsElRCtjg/view?usp=sharing

1 Like

Good day, did you check the pinout? on what kind of fc?

Yes. GPS works fine. Compass data stream is coming too.

I will compile the latest firmware for it and test it on the same model of Gps

So just try last compiled firmware…i’ve tested it without issues
AP_location one periph.bin (107.4 KB)

I’ll give it a try and update you.
Thanks

Same issue again.
First attempt
Google Photos
Second calibration attempt
Google Photos

@tridge @rmackay9 any suggestions?

Not the location one but I have a few rm3100 compasses on CAN that work with zero issues

Hey @rmackay9 @Dave84
Okay. Tried very good number of calibrations with AP_Periph for M10070 latest firmware. It looked like compass calibration was very successful without GPS fix.


Once the GPS fix was established, the compass started to show “BAD Radius”. I thought it was something to do with COMPASS_AUTODEC. But even after disabling COMPASS_AUTODEC and redoing, the issue persists.
https://drive.google.com/file/d/1pU8tPy_K1K5spdQBsBUbquejQXxWMXuo/view?usp=sharing
What I feel is, this has to do something with AP_Periph CAN packets(Just a thought).
@pkocmoud, does location one do any correction wrt to GPS onboard?
Also, I don’t know why I’m the only with the issue.

What hardware are you using?
I have some on I2C. Would love see something on CAN.

I am using the CUAV NEO PRO V2 gps/compass

That being said I also have 2 MRO can rm3100 compasses that I have yet to plug in and test

its weird…, how did you set te CAN on parameter tree?

As usual. No parameters were changed on location one except for the node ID.

ok… did you set Gps type as uavcan and enable only P1 can drive in the Parameters tree?

Of course. I have mentioned previously that GPS and compass data is shown on MP. Only problem is compass not getting calibrated.

Just checking, but have gone out and waited for a good 3D fix before doing compass calibration?

Yes. Have tried with good 3d fix. Same “Bad radius” problem.

i will do some test with my location and let you know

Okay.
Calibration 1: AutoDec=1, No GPS fix(Compass Calibration Successful)
Calibration 2: AutoDec=1, 3D GPS fix(Unsuccessful)
Calibration 3: AutoDec=0, 3D GPS fix(Unsuccessful)
Calibration 4: AutoDec=1, Disabled GPS(Compass Calibration Successful)

So, It looks like it has to do something with data stream. Maybe compass packet loss when GPS is enabled?
@tridge @rmackay9 reallly need some assistance here. I’m almost in the stage of chucking this GPS.
Some logs for reference.
https://drive.google.com/file/d/1neNK8tm-uHnz9DbUAWARpgZc4RhLnFO4/view?usp=sharing
https://drive.google.com/file/d/1X6fbX-w4Fx1v387XXXiDvbBhOGFK64Zs/view?usp=sharing
https://drive.google.com/file/d/1yERUfZ1ktAwvO_tuDyLW2GMFmgT0q7-_/view?usp=sharing

Servers by jDrones