Servers by jDrones

Limit Wind fighting in Auto mode

Hello there again :wink:

Our LTE Long range Quadcopter build and configuration is done and we made the first long range (14km) auto mission today.

The mission was through a valley and i wanted to do exactly the same mission twice, once with the 10Ah battery (6S) and once with the 18Ah battery (6S) The first mission at 01 Pm succeded perfectly, the Auto mode was set to a speed of 14m/s (50km/h)

then after some reviewing of the logs and changing the battery, mission 2 started at 03:30 PM. after a few 100 meters i noticed lot of shaking on the HUD, GPS Glitch and High Z-Axis vibration.

i returned to Loiter mode and manualy fly back to the Launchpad. luckily without any damage or data link loss.

After reviewing the log and weather data from the local weather station i noticed that the wind increased meanwhile.

In the first flight the copters Pitch was about -20 degrees to reach target and -10 to come back. the -20 seems to be close to the limit before vibrations will rise.

in the second flight the pitch raised up and up to -30, i then canceled the mission because i felt unconfortable. so back in loiter pitch was still at -10 degrees in hover.

so here the question:
is there a way to set the max angle in Auto mode seperately or another way to limit the copters “wind fight behavior” to make sure the pitch will stay below -20?

i do not want to limit the angle overall, in RTL it can be important to go over that limit to reach home even when not flying stable…

any other suggestions about why virations are getting high at high airspeed would be highly appreciated. we are talking about a quadcopter with 17 inch propellers and BLheli ESCS (in D-Shot protocol)

Could you please post the on-board flight log (.bin file) so we can take a close look at the situation? Sending both logs (10Ah and 18Ah battery configurations) might help better.

The wind estimation and setting limits is coming soon to arducopter

1 Like

Can you post graph of Vibration level (vibe xyz)? And did you apply Notch filter?

Thank you for your replies, please find the Log files here: http://office.swissrope.com/sharing/TKeNEFwUD

Something i noticed too is that the GPS status sometimes goes to 1 in both mission for a very short period of time. can this have something to do with the vibrations? anyway i am just adding a 2nd GPS for further investigation and safety.

I did not yet applied any notch filter, but thank you for the hint, i think INS_HNTCH_MODE = 3 might be worth a try?

Those Z vibrations are definitely too high and will lead to serious issues.
Z is usually a problem with flight controller antivibration mounting, but can also be prop wash over the flight controller. Check your X and Y vibes too, usually prop balance, but can also be wiring pulling on the flight controller or bumping the FC.

thanks, X and Y are always below 30, it is just the Z axis having issues. i do not have any antivibration mount, the cube is bolted right on the frame. do you recommend to use some antivibration mount?

From lot’s of anecdotal evidence (I don’t have Cubes),and hard facts posted as logs before and after, “Hard mounting” with the supplied foam tape only works well on very rigid frames. The internal isolation is insufficient for compliant frames. But there is a steady drumbeat of “must be hard mounted” with these FC’s so take it as you see it.

With Vibes and clipping events off the charts you are lucky Vibration Compensation FS hasn’t been activated. Then things can go sideways quickly.

This is not what you should be worrying about. Also, running this on default parameters is likely not wise. With 17" props on 6S at least set these basic initial tuning parameters, round up on the filters, after fixing the Vibe issue.

Params

Then read thru the process for setting the dynamic notch filter. Complete that then do an Auto Tune.

thank you for the reply, i did another test today with the small battery and reduced the speed to 10m/s vibration stayed well below 25 all the time (this is ok right?)

yeah, it is almost a religious question if the cube should be mounted on foam or not :wink: what kind of foam / vibration dampening do you recommend?

i also investigated the mentioned GPS issue and solved it, was a faulty cable. nothing to worry i am flying with 2 GPSes anyway.

i activated the dynamic notch filter and it might fly better, difficult to say. do i need to redo the auto tune now? (already done before) also do i have to do the process with the values you have mentioned if the auto tune is already done and the copter hovers very well and stable?

btw, the frame is pretty strong, aluminum frame. will post a photo of it tomorrow.

You can’t just activate the notch filter. It requires a minimum of 2 flights with multiple parameters to set during the process. Each craft is unique.
Tune sequence:
Set initial parameters
Set dynamic notch parameters
Perform Autotune

The ball mount plates work well in most cases.

Please do follow the instructions posted by Dave. I will probably solve your issues.

Hey guys
thank you for your advice. sorry for letting you wait for a while. i had a issue with the GPS, was solved with replacing the carrier Board of the cube.

i then adjusted the values as proposed by Dave and made a test flight. flown pretty well, similar like before but a little less aggressive, especially the yaw.

so i performed the auto tune in Loiter, after it was done i tested the flight behavior and noticed that it was worse than before. especially in loiter, holding the position was way less accurate than with the old PIDs. so i landed with the switch Autotune Off, charged the batteries and performed the auto tune in AltHold mode. The tuning for the Yaw took a little longer than the Pitch and Roll. anyway it succeded, flight behavior was better than the (loiter) autotune before but still not better than the old PIDs. so i landed again in Autotune Off to return to the old PIDs.

i must have missed something, the first time i made the autotune with the notch filter off, it was a huge difference after…

i am pretty happy with how it behaves now (at least with the small battery, didn’t test the big), but i am wondering why the auto tuning was no satisfying success.

The Log Files are available under the same download link like mentioned above.

Thank you for your help.

Here some Pictures of the Quad:



We never saw the logs for the multiple flights required to set the Notch filter parameters. Simply enabling them with default parameters is pointless. If you want to do it right then set INS_LOG_BAT_MASK to 1 then make another Hover flight in AltHold for ~1min. The post that log. Then the notch parameters will be determined and set and you will make another flight to check to see if it’s effective. Then you would run Auto Tune.

Thank you dave for your help. i learned a lot about the dynamic notch now…

unfortunately the manual does not go much in detail if using BLHeli telemetry data…

so i did the hover like you requested (finally the weather allowed it) once with
INS_LOG_BAT_MASK = 1 (named Hover1.BIN) i then adjusted some values like i believe it is right and made another flight with INS_LOG_BAT_MASK = 2 (named Hover2.bin)

(the logs are available under the same download link like the others)

Thank you for helping me out.
Jason

Not bad. I would change these parameters as follows:
INS_HNTCH_ATT,40
INS_HNTCH_BW,23
INS_HNTCH_FREQ,46

You want the filter active over the frequency range seen and there is small peak ~46Hz (frame mode probably). The harmonic of this is the big peak and it will be attenuated with a BW 2X the 1st harmonic setting or 46Hz in this case.

I would make these changes and then run Autotune and you should be set.

cool, thanks. i’ll try tomorrow.

cheers

Edit: heavy snowfall today, no flight permission :wink:

Looking at the pictures I would suggest to fix some of the cables in place. It looks like they can flap around in the wind and the GPS cables even hitting the FC.

40 is out of range, i’ll try with 30?

Ignore the out of range message

Servers by jDrones