Servers by jDrones

Liftoff problem

Pixhawk 2.4.8 is not lifting off the ground. all calibration done but the drone id tilting backwards and not able to liftoff

Hi @virajsimpi. It’ll be really tough for anyone to help you here if you do not provide the logs. Please consider attaching the relevant logs in this thread!

The motor order is probably not correct. And please post a binary log file.

read this thread… Drone does not take off, wants to fall on its side!

How exactly does one determine the correct motor order? Both mission planner and QGC have pictures of the aircraft with no labels for the motors. The documentation labels the motors with 1-X, but mission planners motor tester labels the motors wit letters. QGC doesn’t have any labels on the motor tester nor on any diagrams.

I assumed that motor A is actually motor 1, B is 2, etc, but performing a standard hand-held stabilization test seems to indicate that the order is not correct, given that the stabilization seems to be correcting in the wrong directions.

That’s not to mention the mapping between servo pin on the flight controller and the motor, etc.

This seems like a fundamental safety issue that really needs to be addressed.

10 12-31-1979 4-00-00 PM.bin (217.9 KB) 2020-04-23 12-40-23.tlog (279.9 KB)

We have tried calibration a lot of times, changed the motor polarity and direction and still the drone is going backwards during takeoff. Its is not getting lifted and on giving high throttle it is flipping. We even tried reducing the PID gain values and also tried to adjust the trim, nothing seems to effect much. Please help us with this situation

Do not change just the polarity. Fix the order AND polarity.

Why assume that. Just read the Note and click the link on the Motor Order Page? It takes you here:

I did click the link and got a 404 error.

Edit: This is the link it takes me to: https://ardupilot.org//docs/connect-escs-and-motors.html

Update Mission Planner, link works for me. Using latest Beta is usually the best choice as Mission Planner often trails Ardupilot features. In any case it’s on the Motor Order page of the Wiki that you would need to determine the order to begin with:
https://ardupilot.org/copter/docs/connect-escs-and-motors.html#motor-order-diagrams

That’s the documentation that I was referring to that shows them numbered 1-4. Where did you get the picture with them A-D?

Oh, and they are in different orders if you assume A=1, B=2, etc…

Same place, page down.

No assumption of that. I mean sure many have made that mistake. For example, there were some that were taking the order from the picture of the frame on a Tarot product box with motor numbers shown…

If we don’t change the polarity of the motor all the motors are rotating in the same direction. How to solve the problem?? I have uploaded my logs before .

What do mean “polarity of the motors”? Change direction as required in ESC firmware or if that is not available swap any 2 of the 3 motor leads.

Looking at your logs the RCx input values are all over the place. Center the Transmitter trims and never touch them again (they are not used for a multirotor) then perform another Radio Calibration.

And obviously follow the instruction on the Motor test page for order and direction.

Are you only using the Flight Controllers internal compass? Not the best idea.

Set the PID’s back to default. That will not fix this problem.

That doesn’t ring some warning bells?

Also, I don’t see how that fixes the problem. It does provide a couple of examples of mapping the letters to numbers, but what if ones aircraft doesn’t fit one of those examples? How does one, in general, know what motor “motor A” should be on their aircraft? Am I missing some connection?

Also, why not just put the motor numbers in the GUI and eliminate all possibility of confusion?

In any case, thank you. This does answer my question and will likely solve my problem.

All the frame types that are supported are addressed. For flat motor layouts it’s Front Right (X) or Forward (+) A then clockwise A-X. For co-axial s it’s covered also. Yea, you have to read the Wiki and maybe it’s not intuitive until you understand the logic of doing it this way. Which is, no matter what frame (Tri, quad, hex octo) the Test order is the same.

Yes i got that… Thank you. But still my quadcopter is not able to liftoff. What is the problem? I have done all calibrations and installed the firmware again but the problem persists

Just some extra information for some interested users having problems with motor order. There is a user-settable parameter called “FRAME_TYPE”. If you set it as 14, you can have your motor ordering clockwise. So 1 is front right, 2 is back right and so on. To set how many motors the vehicle has (quad, hexa, octa, etc) one can use the “FRAME_CLASS” parameter.

1 Like

Post your parameter file again. Transmitter set to AETR/1234? In Mission Planners HUD does the artificial horizon move correctly when the craft is pitched/rolled. In the Radio Calibration screen do the functions match the Transmitter?

That’s a good point. And these:

1 Like
Servers by jDrones