Servers by jDrones

LIDAR-Lite V3HP don't work


(igor faleiro) #1

I

garmin Sem%20t%C3%ADtulo

I’ve been trying to use my Garmin Lidar V3HP with my pixhawk 2.1 via I2C and it worked for a few minutes when it was conected like recommended in Ardupilot.org (picture) but after I turned the system off I couldn’t get any data from it anymore. To check if the lidar was working I used an Arduino and it worked fine with it but never with my Pixhawk. I also tried to get a read via PWM also unsuccessfully. After checking that the sensor was working I tried to use pull up resistors like recommended in Garmin’s manual (picture) but it didn’t work too. I also tried to invert the SCL and SDA cables position in the conector. I’ve been using a life battery (6,6V) to power the sensor. To check if it could be an over tension issue I also tried with a 5V BEC which also didn’t work.
The parameters set in mission planner were like recommended (pictures). I also tried every single type in the parameter RNGFND_TYPE.

Does anybody have any ideia of what could be happening?


(ppoirier) #2

I don’t see a dedicated BEC in the picture to supply the rangefinder, I read you tried but it is required, and don’t forget to connect both grounds together

V3HP is type 21


(FRED GOEDDERT) #3

17 days ago I build a cable to connect one of my LidarLite v3 to PH 2.1 to the I2C 2 connector . But I am also using for power a UBEC (5V) with a 680uF capacitor.
FW=3.6.3 chibios. I got it working immediately. If you stick to the connection diagram you are showing above you will have success or you have hardware problems.


(David Koukourou) #4

I have the same problem. how can I tell if its a hardware problem? It works with I2C on an arduino perfectly.


(igor faleiro) #5

My problem was solved after I put 2 capacitors of 47pF. To check if it’s a hardware problem, you can test the pixhawk i2c port with an airspeed sensor (pitot). I will put the photos identifying the connections.