Servers by jDrones

Lidar based Altitude Control

Hey guys,

I am looking to integrate a Terabee 60m Lidar into my aircraft for altitude control. I have it working in that the Range Finder 1 shows accurate measurements - but I am unable to get it in use for altitude control. It always says “Bad LiDAR Health” on MP. Anyone know how to fix this?

Also - I would ultimately like it to use the sensor to adjust altitude over a hill during loiter flight. Basically terrain following but in loiter. Is this possible?

Did u power it ddirectly from the flight controler or used a separate BEC?

I have it running off of a 5V3A BEC. I can replace it if you think it’s a power problem maybe? Like I said, I am getting accurate readings.

Hi

I’m using a TeraBee Ranger Evo 60m since last year. The sensor works so far, but I also get the message “Bad Lidar Health”. How far from the ground is your terabee sensor mounted? I think the problem is caused by the minimal reading distance from the sensor (0.5m). Despite that, I’m able to fly auto mission with takeoff and RTL commands.

Terrain Following also work in Loiter if the sensor provides data.

2 Likes

I had the same Bad Health Lidar problem when I integrated the Terabee 60 m and I solved it by adjusting the minimal reading distance from the sensor parameter as Michael says.

I have the min range set to 50cm and the max to 60m. Distance from bottom of aircaft to ground at rest is about 10cm. I am getting accurate sensor data throughout flight - but it doesn’t seem to be using the LiDar for altitude control. For instance, aircraft altitude shows 5m but lidar shows 4m. How do I go about making the autopilot use LiDar for main altitude control.

Not sure if arducopter corrects only 1m deviation…

Can you try to fly over some hilly terrain (or maybe a roof or a small bush) in Loiter wihout do any throttle adjustment? You should see that the drone follow the terrain.

Thanks for all the feedback folks.

So - I flew over a container roughly 4-5m tall and it did not adjust altitude to remain at a constant AGL above the surface. Lidar shows the new measurement - but altitude does not adjust.

That’s bad… Can you share a log from the last flight?

BTW, I assembled today a new drone with a TerraRanger Evo 60m. I also get the bad Lidar Health message. But only under 50cm where the sensor doesn’t read anything.

I will test hopefully tomorrow if the sensor works in auto mission.

1 Like

I’ll be able to get back to it come Monday and will send a log then. Thanks for your help!

I find the root cause for this issue. The parameter TERRAIN_ENABLE was mistakenly set to 1. Do not enable it if you are using a rangefinder.

we have an issue with Loiter flight mode + Rangefinder + flow sensor. Hope someone is interested to take a look and provide good suggestions.

Servers by jDrones